Opened 14 months ago

Last modified 4 months ago

#14593 confirmed Bug

CHROME: Copying & pasting content from one editor instance to another removing all styles

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.0
Keywords: Blink Webkit IBM Cc: chrisgui, irina

Description

Steps to reproduce

  1. Open nightly build http://nightly.ckeditor.com/16-04-18-06-06/full/samples/ in two tabs
  2. Add text in one editor and apply different formatting to text(ex: font name, font size, text/background color, Alignment, Indentation)
  3. Select the text & use Ctrl + C to copy the text
  4. Go to editor in next tab, clear existing content & paste the copied content from editor in previous tab

Expected result

Pasted content should have all the styles of the txt copied from previous editor

Actual result: Pasted text has no styles

This is a regression in 4.5 & it's working properly in 4.4.8

Change History (7)

comment:1 follow-up: Changed 14 months ago by j.swiderski

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #13860.

comment:2 in reply to: ↑ 1 Changed 14 months ago by satya

Replying to j.swiderski:

This is a duplicate of #13860.

@j.swiderski this defect has more issues than mentioned in #13860. #13860 only talks about inline styles but in this defect we mentioned Indentation Alignment are also lost ( which are not inline styles). Pls mark #13860 as duplicate of tis, since it's a subset of this issue.

comment:3 Changed 14 months ago by j.swiderski

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version changed from 4.5.9 (GitHub - master) to 4.5.0

comment:4 Changed 14 months ago by j.swiderski

  • Keywords Blink Webkit added
  • Status changed from reopened to confirmed

#13860 was marked as duplicate

@satya you are right. This ticket describes the problem in more detail.

comment:5 Changed 14 months ago by j.swiderski

#14617 was marked as duplicate

comment:6 Changed 13 months ago by satya

@j.swiderski This is also happening in Safari on MAC & also an issue when Copying & pasting Tables. Al Table Properties are removed

comment:7 Changed 7 months ago by j.swiderski

It turns out we have quite a few issues with pasting and they all may be related as they all can be reproduced from 4.5.0:
Styles Stripping: #13860, #13926, #14250, #14358
Styles stripping on Chrome in various test cases: #14921, #14593, #13753, #13751, #16454
Weird event pasting relation (not sure): #13763
White spaces not preserved: #14614
Problem with pasting in LibreOffice: #14622 (we do not support it but I have added this issue because general solution might also bring back old behaviour).

Last edited 4 months ago by j.swiderski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy