Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#209 closed Bug (fixed)

Netscape 7.1: URL portions in links are replaced with $5

Reported by: dustball Owned by:
Priority: Normal Milestone: FCKeditor 2.4.1
Component: General Version: FCKeditor 2.4
Keywords: Netscape Confirmed Cc:

Description

  1. Download Netscape 7.1 @ http://www.oldapps.com/netscape.htm
  1. Load editor at http://www.fckeditor.net/demo or http://klug.pbwiki.biz/FCKeditor/2_4/_samples/default.html
  1. Switch to source mode

The HTML has been corrupted:

<a href="http://www.fckeditor.net/$5">FCKeditor</a>

If you switch back to normal mode, and back again, it will keep adding $5$5. Sometimes, it will add $4 to the beginning of the URL and similar bugs.

Change History (2)

comment:1 Changed 10 years ago by alfonsoml

  • Keywords Confirmed added
  • Version set to FCKeditor 2.4

The problem is in the ProtectUrl:

	ProtectUrls : function( html )
	{
		// <A> href
		alert(html);
		html = html.replace( FCKRegexLib.ProtectUrlsA	, '$1$4$2$3$5$2 _fcksavedurl=$2$3$5$2' ) ;
		alert(html);

		// <IMG> src
		html = html.replace( FCKRegexLib.ProtectUrlsImg	, '$1$4$2$3$5$2 _fcksavedurl=$2$3$5$2' ) ;

		return html ;
	},

comment:2 Changed 10 years ago by fredck

  • Milestone set to FCKeditor 2.4.1
  • Priority changed from High to Normal
  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [210]. The Netscape 7.1 regex engine is a little bit buggy, so I have reviewed the regex (and as a plus, simplified and optimized it).

By the way, the technology (Gecko) in Netscape 7.1 is quite old and buggy. I'm not sure will compatible with that old browsers with FCKeditor 3.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy