Ticket #2353 (closed Bug: invalid)

Opened 6 years ago

Last modified 3 years ago

Image resized by mouse doesn't preserve its new size on save

Reported by: cableguy Owned by: None
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5.1
Keywords: HasPatch Cc:

Description

Hi, I´m running FCKeditor in Mediawiki 1.12. I am having trouble with the image uploading. I have 2 main issues:

  1. When selecting an image, the preview doesn´t appear
  2. I can resize the image with the mouse but when I save the page it goes back to its original size.

I´ve already checked out ticket #407 and its fix in Changeset 339; my fck_image.js is just like 339 but still I´m experiencing trouble.

Q: Is FCKeditor 2.5.1 the newest version for Mediawiki??

Thanks, cableguy

ps: running Apache 2.2

Attachments

2353.patch (3.5 KB) - added by fmss 6 years ago.

Change History

comment:1 Changed 6 years ago by cableguy

  • Priority changed from Normal to High

comment:2 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added; image upload resize IE7 removed
  • Priority changed from High to Normal
  • Summary changed from Image upload + resize to Image resized by mouse doesn't preserve its new size on save

Firstly the answer to your Q is: Yes, you may download the newer version of FCKeditor and place in your MediaWiki.

  1. The preview in the current release work as expected.
  1. Confirmed in IE and FF. The image size isn't placed inside the wiki image attributes. For now you can bypass this problem by setting the image size in the image properties window.

comment:3 Changed 6 years ago by cableguy

ok..not the answer that I was expecting but anyway thanks...

another Q: May it be possible that installing my Mediawiki on Linux solve the problem? Originally my installation was on Windows XP SP2

comment:4 Changed 6 years ago by fmss

  • Status changed from new to closed
  • Resolution set to fixed

Patch attached. Tested with FF3 and IE7.

comment:5 Changed 6 years ago by fmss

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:6 Changed 6 years ago by fmss

  • Owner set to fmss
  • Status changed from reopened to new

Changed 6 years ago by fmss

comment:7 Changed 6 years ago by fmss

  • Keywords Review? added; Confirmed removed

comment:8 Changed 6 years ago by fmss

  • Owner changed from fmss to None

comment:9 Changed 6 years ago by fmss

  • Keywords HasPatch added

comment:10 Changed 6 years ago by wwalc

  • Keywords Review+ added; Review? removed

I tested it on IE6 and FF2 and it seems to work fine.

Fixed with [3179].

comment:11 Changed 6 years ago by wwalc

  • Keywords Review- added; Review+ removed

Ok.. while working on some other problem related to images it turned out that actually this patch had some bugs, so I reverted it with [3181].

Problems: even if image has not been resized with a mouse, [[Image:Foo.jpg]] has been always changed into [[Image:Foo.jpg|311x233px]] or [[Image:Foo.jpg|nullxnullpx]]

A partial fix for this bug has been committed with [3182]. Should work in FF, in IE it will only work if image has been already resized or if it has been resized using the image dialog box for the first time, so I'm not closing this ticket yet.

comment:12 Changed 3 years ago by j.swiderski

  • Status changed from review_failed to closed
  • Resolution set to invalid

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy