Ticket #746 (closed Bug: wontfix)

Opened 7 years ago

Last modified 5 years ago

Comments inside SELECT and OPTION tags.

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: SF Confirmed IE CantFix Cc:

Description

Internet Explorer removes HTML comments which are inside SELECT and OPTION tags.

As an example:

<form><!-- form -->
<select><!-- select -->
<option><!-- option --></option>
</select>
</form>

becomes:

<form>
<!-- form --><select>
<option selected="selected"></option>
</select>
</form>

This also proves to be a problem when working with ProtectedSource since it makes use of comments.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1509346&group_id=75348&atid=543653

Change History

comment:1 Changed 7 years ago by martinkou

  • Reporter changed from martinkou to anonymous

comment:2 Changed 7 years ago by martinkou

  • Keywords Confirmed IE added
  • Version set to SVN

comment:3 Changed 6 years ago by arczi

The same bug occurs in 3.0 beta 3667.

comment:4 Changed 6 years ago by garry.yao

  • Keywords CantFix added

IE doesn't allow comments inside SELECT,so it's almost not fixable.

comment:5 Changed 5 years ago by fredck

  • Status changed from new to closed
  • Resolution set to wontfix

Confirmed, this is a browser implicit limitation.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy