Opened 6 years ago

Closed 19 months ago

#8113 closed Bug (invalid)

Position of dialogs when CKEditor is in an iframe

Reported by: aoudin Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.0
Keywords: Cc:

Description

We have an issue with dialogs position when CKEditor is placed in iframes whose height is higher than the screen height. The positionning calculus is based on the height of the viewport (so the iframe height when in an iframe) causing the dialog to be displayed far away (in the middle of the iframe) from the editor itself, because of the iframe height.

To reproduce this behaviour, we have set up a test case at the following address :

http://www.goademo.com/ckeditor/ckeditor_iframe_dialog/

Click on the special character button of the first editor, the special char dialog is displayed in the middle of the iframe and :

  • on chrome, the browser automatically scrolls to the dialog (so users are lost when they close the dialog - because the editor is on the top of the screen)
  • on other browsers (firefox, probably IE), you have to scroll down to retrieve the dialog (so users think that the button doesn't work at all)

Attachments (1)

testpage.zip (1.7 KB) - added by j.swiderski 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.6.1 to 3.0

Copy files from attachment to samples folder, open testpage.html in your browser and open any dialog. You will see that:

Edit:

In CKEditor 4.x and Firefox, Blink and Webkit dialog is opened in the middle of the iframe.

In IE dialog is also opened in the middle of the iframe but page scrolls to it.

Last edited 3 years ago by j.swiderski (previous) (diff)

Changed 6 years ago by j.swiderski

comment:2 Changed 3 years ago by j.swiderski

#11854 was marked as duplicate.

comment:3 Changed 3 years ago by nikhiljbhandari

whats the fix for this issue let me know i am facing this issue on ckeditor version 4.4

comment:4 Changed 3 years ago by j.swiderski

@nikhiljbhandari you can add yourself to CC. You should be notified when changes are made to this ticket.

comment:5 Changed 3 years ago by nikhiljbhandari

please add mee to CC and do let me know once the fix is available.

comment:6 Changed 19 months ago by j.swiderski

  • Resolution set to invalid
  • Status changed from confirmed to closed

I have stumbled upon #9404 and as a result I'm closing this issue as invalid.

Please see comment:4 for more details.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy