Ticket #8499 (closed Bug: invalid)

Opened 3 years ago

Last modified 3 years ago

Safari : List/Link properties not updated when cursor kept at end of list item or link inside table cell and modified properties

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: damo, tmonahan

Description

To reproduce the defect:

Scenario 1:

  1. Open any sample and insert a table
  1. Keep cursor inside a table cell & insert a link with URL (www.bbc.co.uk)
  1. Keep cursor at end of link and open Link dialog from context menu
  1. Change the URL for the link to www.google.ie and click OK button.

Expected Result: URL for the link changed to www.google.ie

Actual Result: URL for the link not changed.

Scenario 2

  1. Open any sample and insert a table
  1. Keep cursor inside a table cell & insert a Numbered/Bulleted list
  1. Keep cursor at end of list item and open Numbered/Bulleted List Properties dialog from context menu
  1. Change the Style for Numbered/Bulleted List and click OK button.

Expected Result: Style for Numbered/Bulleted List changed

Actual Result: Style for Numbered/Bulleted list not changed.

Attachments

Cursor Position for link.JPG (114.9 KB) - added by satya 3 years ago.
Cursor Position for list.JPG (107.3 KB) - added by satya 3 years ago.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by j.swiderski

  • Status changed from new to pending

@satya could I ask you for more details here?

I was not able to reproduce it. Perhaps partialy for the lists. In Mac when you right-click behind the last item a selection is made from last list item till the end of cell. Applying new styles doesn't have the effect then. Is this what you were talking about (I haven't managed to reproduce it for links)?

comment:2 in reply to: ↑ 1 Changed 3 years ago by satya

Replying to j.swiderski:

@satya could I ask you for more details here?

I was not able to reproduce it. Perhaps partialy for the lists. In Mac when you right-click behind the last item a selection is made from last list item till the end of cell. Applying new styles doesn't have the effect then. Is this what you were talking about (I haven't managed to reproduce it for links)?

@j.swiderski I have used safari on Windows to reproduce this issue

comment:3 Changed 3 years ago by j.swiderski

Then I must say that I'm not able to reproduce it (I have double-checked).
Lists and Links are updated no matter what I do.

Could you check this issue on other machine perhaps?

I'm not sure if your description can be more detailed but does this happen always or there are some other extra criteria that have to be met to reproduce the bug (like keyboard usage or mouse at the same height as text)?

comment:4 Changed 3 years ago by satya

@j.swiderski

I can always reproduce the issue for lists. I have attached a screenshot of where to keep cursor postion for list item.

Coming to Links(I'm seeing a diff issue now).Keep cursor at end of link & verify that element path bar shows anchor(a) tag, now right click and see that Link Options are not available in context menu. I have attached a screenshot of where to keep cursor position for link

Changed 3 years ago by satya

Changed 3 years ago by satya

comment:5 follow-up: ↓ 6 Changed 3 years ago by j.swiderski

I will have to ask other to have a look at that.

@satya one more thing. In which version/revision are you getting this error?

comment:6 in reply to: ↑ 5 Changed 3 years ago by satya

Replying to j.swiderski:

I will have to ask other to have a look at that.

@satya one more thing. In which version/revision are you getting this error?

@J.swiderski I'm using nightly build and my Safari version is 5.0.3

comment:7 Changed 3 years ago by j.swiderski

Perhaps this is a reason of us having different results.

Have you tried the latest Safari 5.1.1? Bug doesn't seem to occur there.

comment:8 Changed 3 years ago by satya

@j.swiderski this issue was fixed in 5.1.1. Please close this defect

comment:9 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy