Ticket #9121 (closed Bug: fixed)

Opened 22 months ago

Last modified 22 months ago

CKEditor 3.6.3 full-page edit affects titles

Reported by: zoey Owned by:
Priority: Normal Milestone: CKEditor 3.6.4
Component: General Version: 3.6.4
Keywords: Cc:

Description

The Google Chrome 20x popup issue was the main reason I wanted to upgrade the editor. Once updated with the nightly build of CKEditor and the popup problem was resolved. However, after the update, i'm running into a problem when editing "full page" 4.01 html pages. The page loads fine, but the document title is being removed by CKEditor and appears like this... <title></title>

This problem is even in this website's demo, enter into Source and put a title, and go back and forth between Source and GUI, the title disappears: http://nightly.ckeditor.com/7550/_samples/fullpage.html Interestingly, if you enter the meta tags for descriptions and keywords within the demo, they will appear properly and will not be removed. Copy these into the demo Source code to test...

		<title>Disappearing Title Bug</title>
		<meta content="disappearing title bug on demo" name="description">
		<meta content="title, bug" name="keywords">

Reverting back to the prior backup of CKEditor, and of course, the popup problem returns, but the "full page" editor functions normally with the title appearing correctly.

While on the subject of "full page" editing, the editor performs all its features normally, but it always enters this bit of code <p>&nbsp;</p> just before the </body> statement. This code is added and appears after entering the editing box when in the GUI mode. In summary, the perfectly coded W3C validated html page has this new code added when entering into the GUI editor box.

For reference purposes, the editor doctype in config.js is configured to publish 4.01 Transitional html pages to ensure web pages display on various browsers. Additionally, I've updated to the latest CKFinder, but the popup issue remains. Thus, I'm using (reverted to previous) CKEditor 3.6.1 with CKFinder 2.2.2.

I hope these notes help in resolving these issues soon. Thank you for all that you do.

Change History

comment:1 Changed 22 months ago by wwalc

  • Status changed from new to confirmed
  • Version set to 3.6.4 (SVN - trunk)
  • Milestone set to CKEditor 3.6.4

Thanks for the nice and clean description!

Simplified TC:

  • load _samples/fullpage.html
  • switch to source mode
  • result: the title is gone

Introduced in [7499]. Affects all non-IE browsers.

Possibly caused by adding in wysiwygarea/plugin.js

CKEDITOR.env.ie &&

before

editor.on( 'contentDom', function()

(guessing).

Last edited 22 months ago by wwalc (previous) (diff)

comment:2 Changed 22 months ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed

Fixed with with [7564], tks for figuring this out.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy