Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#10769 closed Bug (invalid)

Move smiley into editor with bb-codes fail

Reported by: Dennis1993 Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: 4.2
Keywords: Cc:

Description

Hey guys,

I think, I have found a bug. I habe downloaded the full package of CKEditor 4.2 with the bb-code output plugin. After downloading I extract it and open the samples in the browser. Now I select the entry Output for BBCode and open this file in my PHP editor too.

Now I place a smiley in the text e.g.

<img src="../../../plugins/smiley/images/angel_smile.gif" alt=":)">

Now I refresh the site in the browser. The site looks like this: see attachment ckbug1.png, please! So, now I drag and drop the smiley in the editor and press submit. See attachment ckbug2.png, please!

The output code is now the following:

This is some [b]sample text[/b]. You are using [url=http://ckeditor.com/]CKEditor[/url].

Where is the smiley? If I select the smiley and the text after it and drag and drop it to the CK-Editor and press submit, the text after the smiley is not transmitted.

Is it a bug? How can I fix it?

Thanks in advance!

Attachments (2)

ckbug1.png (101.7 KB) - added by Dennis1993 6 years ago.
ckbug2.png (120.3 KB) - added by Dennis1993 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Dennis1993

Attachment: ckbug1.png added

Changed 6 years ago by Dennis1993

Attachment: ckbug2.png added

comment:1 Changed 6 years ago by mikey

I can understand that. For me it does not work. If you click on source code by inserting times, you can't go back. The editor then hangs completely.

comment:2 Changed 6 years ago by Dennis1993

Yes, that's right. I have the same Problem by testing.

Thanks for your comment!

comment:3 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I can't agree this is bug. You have chenge value in alt attribute and Editor's bbcode plugin uses alt to resolve correct bbcode symbol for image

alt = attributes.alt;
	if ( src && src.indexOf( editor.config.smiley_path ) != -1 && alt )
		return new CKEDITOR.htmlParser.text( smileyMap[ alt ] );

As you probably know there is no standard for bbcode and bbcode plugin is in fact something like a starting point to create your own "bbcode parser".
We have chosen such solution for this plugin and in our opinion it is correct.
If anyone doesn't like it he can always alter it.

I'm closing this issue as invalid.

@Dennis1993 if you have anymore remarks or don't agree please leave a comment and I will reconsider reopening this ticket.

Version 0, edited 6 years ago by Jakub Ś (next)

comment:4 Changed 6 years ago by Dennis1993

Hey j.swiderski,

thank you for your comment. I've tested this bug with the CK-Editor 4.3 Beta from today. In this version it works perfectly, I can't reproduce it. So, I think, in version 4.3 is the problem solved, so I must wait.

I have tested with many alt="" values but nothing work with 4.2.1.

But in the current 4.3 I can't see the smiley dialog in the samples although defined in the toolbar. It is right?

Thanks!

comment:5 Changed 6 years ago by Jakub Ś

I have just tried smileys in 4.3. There is no change in behaviour.

If you want to D&D smiley image into editor it needs to have same name used for alt as it is used in smileys map. For example smiley face is defined in map as "smile". The same name has to be used for alt.

comment:6 Changed 6 years ago by Dennis1993

Hello j.swiderski,

thanks you for your answer. I have tested it again and now it works. Thats the problem. If I set the alt to the name how you discribed, the editor works perfectly.

THANK YOU, now I'm happy :D

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy