Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10945 closed Bug (fixed)

Click with mouse inside editor does not show the caret, but user is able to enter text

Reported by: ctrl Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.2.2
Component: General Version: 4.0 Beta
Keywords: Chrome Cc:

Description

It seems there is a bug, which appears in Chrome.

How to reproduce:

  1. Load CKEditor WITHOUT any text in Chrome (tested with 30.0.1599.66)
  2. Click with the mouse in the middle of the textarea. It seems by default CKEditor creates an paragraph with br element inside. If you click with the mouse inside, it will work.

Result - the caret does not show, but user is able to enter text.

The same works fine with all other browsers.

See the attached file for more information.

Attachments (1)

bug_report.gif (145.6 KB) - added by ctrl 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by ctrl

Attachment: bug_report.gif added

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Chrome added; chrome caret removed
Status: newconfirmed
Version: 4.2.14.0 Beta

Problem can be reproduced on Chrome (version 30 at the time of writing) only from CKEditor 4.0 beta.

This issue was also mentioned on SO: http://stackoverflow.com/questions/19179167/ckeditor-cursor-does-not-displayed-on-focus/19181205

Version 0, edited 6 years ago by Jakub Ś (next)

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.2.2

This is annoying. Let's see if we're able to fit it in the 4.2.2 in the short time we have for it.

comment:3 Changed 6 years ago by Piotr Jasiun

I'm playing with this and cursor doesn't appears when you click outside paragraph. You may have a content in an editor but if you click below last paragraph cursor may not appear.

comment:4 Changed 6 years ago by Piotr Jasiun

comment:5 Changed 6 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:6 Changed 6 years ago by Piotrek Koszuliński

So it's very likely that setting contenteditable="true" on HTML element will help:

-      else if ( CKEDITOR.env.webkit )
-        doc.body.parentNode.contentEditable = editable;

But it can break tab key then ;/ And even if not I'd try to not start code branching there (in wysiwygarea), because it may have huge impact on other things.

comment:7 Changed 6 years ago by Piotr Jasiun

Status: assignedreview

Fixed in branch t/10945. If user click on html element I set focus on editable. There are no tests.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I pushed one commit to rebased t/10945. This small hack works perfectly.

comment:9 Changed 6 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed
Last edited 6 years ago by Piotr Jasiun (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy