Opened 6 years ago

Closed 6 years ago

#11078 closed Task (fixed)

MathJax sample should mention that MathJax widget does not support IE8

Reported by: Piotrek Koszuliński Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.3
Component: Documentation & Samples Version:
Keywords: Cc:

Description

Due to frequent crashes on IE8 it is important that developers know that MathJax won't work on IE8.

Change History (8)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Component: GeneralDocumentation & Samples

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

I agree that we can go ahead without IE8 compatibility on this plugin right now. Let's have an alert in the page, but make it display for IE8 users only.

comment:3 Changed 6 years ago by Piotrek Koszuliński

I don't think that hiding it for non-IE8 users is a good thing. We have to notify developers that MathJax won't be compatible with IE8, not end users.

comment:4 Changed 6 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: newassigned

comment:5 Changed 6 years ago by Piotr Jasiun

At the moment I will add big red message in IE8, but I think that it should not be displayed in other browser.

I also think that in 4.3.1 we should replace MathJax with placeholder there. To fixed all IE8 problems we would have to go inside MathJax library code and it would be a waste of time (considering the very weak support from MathJax team). I created ticket for this: http://dev.ckeditor.com/ticket/11085.

Version 0, edited 6 years ago by Piotr Jasiun (next)

comment:6 Changed 6 years ago by Piotr Jasiun

Status: assignedreview

Changes in t/11078.

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:8 Changed 6 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy