Opened 6 years ago

Closed 6 years ago

#11131 closed Bug (fixed)

Divarea + widget breaks when switching to source mode while having nested editable focused

Reported by: DrColossos Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.3.2
Component: UI : Widgets Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Olek Nowodziński)

  1. Open image2 sample.
  2. Focus nested editable (caption).
  3. Click "source" button.

Following error will be thrown:

Uncaught TypeError: Cannot call method 'getStartElement' of null editor.js:785
CKEDITOR.tools.extend.elementPath

Attachments (2)

cke-divarea.png (17.3 KB) - added by DrColossos 6 years ago.
1.html (1.2 KB) - added by Marek Lewandowski 6 years ago.
standalone TT using funcitons introduced in #5217

Download all attachments as: .zip

Change History (13)

Changed 6 years ago by DrColossos

Attachment: cke-divarea.png added

comment:1 Changed 6 years ago by Piotrek Koszuliński

Component: UI : Source ViewUI : Widgets
Description: modified (diff)
Keywords: widget divarea source removed
Milestone: CKEditor 4.3.1
Status: newconfirmed
Summary: Divarea + Widget breaks source switchDivarea + widget breaks when switching to source mode while having nested editable focused

I simplify the ticket description.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.1CKEditor 4.3.2

Rearranged tickets due to new ones which have high priority.

comment:3 Changed 6 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:4 Changed 6 years ago by Marek Lewandowski

Seems that solution for this issue will also fix #11139

comment:5 Changed 6 years ago by Marek Lewandowski

Fix for this issue is already prepared, however we still need to prepare TCs for that issue ( contentDomUnload event firing in each wysiwyg mode ) - for that i'll wait for PJ tests modifications, which will run given test in each wysiwyg mode.

Version 0, edited 6 years ago by Marek Lewandowski (next)

comment:6 Changed 6 years ago by Olek Nowodziński

Description: modified (diff)

comment:7 Changed 6 years ago by Piotrek Koszuliński

#5217 will take some time, so to unblock this ticket I pushed to master tools created in t/5217b.

comment:8 Changed 6 years ago by Marek Lewandowski

Status: assignedreview

Additionally i found that inline editor does not fire contentDomUnload event. My understanding is that it should fire it, however i didn't want to implement it without additional confirmation.

Initially i've created tt using function mentioned in comment:7 ( which will be attached to this ticket ), but later on i wanted to include it to ckeditor-tests-v4/dt/core/editable/events.html, so in order to fit it there I had to adjust code to its state.

As a result i've suggested changes in ticket #11363

Changes commited to t/11131 at dev and t/11131 at tests.

Changed 6 years ago by Marek Lewandowski

Attachment: 1.html added

standalone TT using funcitons introduced in #5217

comment:9 Changed 6 years ago by Piotrek Koszuliński

Owner: changed from Marek Lewandowski to Piotrek Koszuliński

Pushed t/11131b (dev, tests) with contentDomUnload fired for every type of editable upon detaching.

comment:10 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

comment:11 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:2699ee7 on dev and 149cefd on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy