Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11173 closed Bug (invalid)

Regarding Undo

Reported by: Subash Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version:
Keywords: Cc:

Description

I have configured the undo size as mentioned below,

config.undoStackSize = 50;

In some case it stops doing undo but the undo icon is enabled which means that there is still more to undo but not performing fully, so that i have to refresh the page and start my tasks again.

Please guide me to resolve this problem.

Thanks in advance.

Attachments (1)

Screen Shot 2013-11-19 at 10.30.19 am.png (56.6 KB) - added by Subash 5 years ago.
Enabled UNDO button doesnot works

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Component: Project : CKBuilderCore : Undo/Redo
Keywords: Undo removed
Status: newpending
Version: 4.2.3

Could you describe scenario and environment (browser, CKEditor configuration, etc) in which undo stays active even though it's not possible to move back? Otherwise we'll not be able to work on that issue and will have to close this ticket as invalid.

comment:2 in reply to:  1 Changed 5 years ago by Subash

Replying to Reinmar:

Could you describe scenario and environment (browser, CKEditor configuration, etc) in which undo stays active even though it's not possible to move back? Otherwise we'll not be able to work on that issue and will have to close this ticket as invalid.

Dear Reinmar,

1. Enter the Paragraph and do some operation.
2. Click UNDO
3. Fourth line is removed
4. Click Undo again - doesn't work 
5. Redo also stops to work and text from the fourth line is not shown after clicking on redo 
6. Both Undo and Redo button is enabled.

----
In Config.js:
I have added to set the Undo Stack size as below,
'config.undoStackSize = 50;'
but still the problem occurs often. 

Please do the needful
Thanks in Advance.

Changed 5 years ago by Subash

Enabled UNDO button doesnot works

comment:3 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
  1. In which browser are you getting this?
  2. Which editor version you use?
  3. I have tried in latest CKFinder 4.3, set config.undoStackSize = 50;, did few as well as more than 50 changes and then undo it all. No problem occurred.
  4. I have noticed in your toolbar that you are using some custom plugins. If this plugin is called track changes than it is quite possible that that it messes up the undo system and you should report it to plugin author.

I'm closing this issue as invalid for now, but if you are able to reproduce this issue in fresh standalone editor that uses only CKSource plugins then please leave the comment and I will reopen this ticket.

comment:4 in reply to:  3 Changed 5 years ago by Subash

Replying to j.swiderski:

  1. In which browser are you getting this?
  2. Which editor version you use?
  3. I have tried in latest CKFinder 4.3, set config.undoStackSize = 50;, did few as well as more than 50 changes and then undo it all. No problem occurred.
  4. I have noticed in your toolbar that you are using some custom plugins. If this plugin is called track changes than it is quite possible that that it messes up the undo system and you should report it to plugin author.

I'm closing this issue as invalid for now, but if you are able to reproduce this issue in fresh standalone editor that uses only CKSource plugins then please leave the comment and I will reopen this ticket.

Browser: Google Chrome Ckeditor Version: 4.3

As you said i have added many plugins. If this is the problem where to raise the query to the respective plugin author. Kindly add the plugins which i have added(refer early attached screenshot) and do the needful. Thanks in advance.


Version 0, edited 5 years ago by Subash (next)

comment:5 Changed 5 years ago by Jakub Ś

where to raise the query to the respective plugin author

You have to report it to plugin author. AFAIK all CKEditor plugins have some sort of website - this can be either some third-party website or website on http://ckeditor.com/addons/plugins/all. You have to report issue on such page to plugin author.

Kindly add the plugins which i have added (refer early attached screenshot) and do the needful

First of all what you have provided is toolbar button. I don't know every plugin and looking them in internet by icon? That is not going to happen.

Second - if you have used CKSource builder then you have the list of plugins installed. If you haven't used the builder then I think you know which plugins are these extra ones. Just remove all third-party plugins, start adding them one by one and see when you will get an error.

Final note: if you have problem with some custom plugin then this is your task to check which plugin is is and report it to plugin author.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy