Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11191 closed Bug (invalid)

"Better Pop Up Blocker" breaks CKEditor

Reported by: Adjungo Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Currently using latest chrome version (Version 31.0.1650.57 m).

You can see it on the demo page of the ckeditor website: http://ckeditor.com/demo

When clicking inside the editor a js error is visible in console: Uncaught TypeError: Cannot read property 'type' of undefined ckeditor.js?mwgvvh:350

All buttons in the toolbar do not work anymore either. Same error when clicked on.

Attachments (2)

Selection_136.png (200.7 KB) - added by Piotrek Koszuliński 5 years ago.
ckEditor.png (287.7 KB) - added by Adjungo 5 years ago.
Screenshot of chrome console

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

I cannot reproduce this. I've got the same version. Could you provide more details what's your OS, addons, etc.?

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_136.png added

comment:2 Changed 5 years ago by Olek Nowodziński

WFM, Version 31.0.1650.57 @ Linux.

comment:3 Changed 5 years ago by Adjungo

OS is Windows 7, all latest updates installed.

Chrome extentions installed:

  • Better Pop Up Blocker
  • Firebug Lite for Google Chrome
  • IE Tab 5.11.13.1
  • TinEye Reverse Image Search
  • Video Downloader professional
  • Vimeo™ Download Videos
  • Web Developer
  • Window Close Protector
  • YouTube Options (Full Version)

Changed 5 years ago by Adjungo

Attachment: ckEditor.png added

Screenshot of chrome console

comment:4 Changed 5 years ago by Adjungo

Just checked on two other machines. Working without issues on those (no extensions installed on either).

Will disable each extension to see if one of those is the cause. If that's the case proper action can be taken as I'm not the only one with thse fairly common extensions.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Keywords: chrome typeError undefined js removed
Resolution: invalid
Status: pendingclosed
Version: 4.3.1 (GitHub - master)

So that's a "Better Pop Up Blocker". Quoting a comment from this addon's page:

This thing is utter crap.

It breaks Facebook, Twitter and CKEditor.

comment:6 Changed 5 years ago by Adjungo

Indeed. When I disable that plugin the editor works like a charm.

Instead of closing this ticket shouldn't a developer see if this issue can be 'fixed/bypassed' easily? Chrome page says installed by 458,619 users. That's half a million people for which ckeditor won't work on any webpage.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Yes, we plan to investigate that. But that doesn't make the ticket valid. We'll report new one, specific for that addon.

comment:8 Changed 5 years ago by Piotrek Koszuliński

Uh... I made a quick look and this addon is terrible. It completely destroys selection. I'm not sure if we'll be able to bypass this.

Version 0, edited 5 years ago by Piotrek Koszuliński (next)

comment:9 Changed 5 years ago by Piotrek Koszuliński

Summary: CKEditor no longer works on latest chrome"Better Pop Up Blocker" breaks CKEditor
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy