Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11233 closed Bug (invalid)

.NET Webbrowser control and IE11 breaks CKEditor

Reported by: Marco Franssen Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

As Microsoft .NET developer we are using the Webbrowser control to open a webpage including CKEditor in order to have an offline html editor in a native windows application.

Since the release of IE11 (Internet explorer 11) CKEditor is broken. The .NET Webbrowser component runs always in IE7 modus (nothing we can do about it).

The issue is very easy to reproduce by putting internet explorer 11 in IE7 compatibility mode. This can be done by openening the developer tools in Internet Explorer 11. (F12 key). And apply the settings as in the attached screenshot.

Then navigate to the CKEditor demo pages. (Javascript issues)

Since our product is worldwide used (150.000 users) and the first companies/users are starting to upgrade to IE11 can't use the html editor anymore.

Can the CKEditor community please solve this issue ASAP so we won't have to change to another solution. We and our users actually love CKEditor and would be happy if we can continue to use it in the future.

Attachments (1)

2013-11-28-10_31_40.png (9.9 KB) - added by Marco Franssen 6 years ago.
IE11 IE7 compatibility mode settings

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by Marco Franssen

Attachment: 2013-11-28-10_31_40.png added

IE11 IE7 compatibility mode settings

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE11 IE7 Compatibility mode removed
Resolution: invalid
Status: newclosed

Ok, this is a little bit complicated but here goes

  1. We have introduced support for IE11 in CKEditor 4.3.
  1. We have dropped support for IE7 in CKEditor 4.2.
  1. What you do isn't valid approach. You should not put browser in to IE7 mode using dev-tools because it gives different results that real IE7. Correct approach here is using X-UA-Compatible tags: <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /> or <meta http-equiv="X-UA-Compatible" content="IE=7" />. First tag is the best approach.
  1. Editor 3.6.4 ASP.NET (with client-side updated to 3.6.6) in IE11 with page set to <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /> seems to work. IE11 is put into IE7 mode so it should work.
  1. Please also note that you may use let's say CKE 4.3 client-side with CKE ASP.NET 3.6.4 server side.
    1. Go to CKEditor site nad download CKE 4.3 FULL Package
    2. Extract it into ckeditor folder
    3. Go to ckeditor_aspnet/_Samples/ and replace existing ckeditor folder with the one you have downloaded. The only thing you won't be able to set from ASP.NET Control is ACF:
      http://ckeditor.com/blog/Upgrading-to-CKEditor-4.1
      http://ckeditor.com/blog/CKEditor-4.1-RC-Released
      http://docs.ckeditor.com/#!/guide/dev_advanced_content_filter
      http://docs.ckeditor.com/#!/api/CKEDITOR.filter-method-addTransformations
      http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-allowedContent
      http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-extraAllowedContent
      which you would have to configure or disable from config.js file.
  2. Since IE7 support was dropped from CKEditor 4.2, then it seems that top most 4.x version to be used with CKE ASP.NET Server-side is 4.1.3 but I have tried CKE 4.3 and didn't get any known issues.

I think you could try using CKEditor one of CKEditor 4.x with CKE ASP.NET server-side (or CKE 3.6.6) and it should work when browser is put into IE7 mode. Perhaps another approach for you would be not modifying IE modes?

I'm closing this issue as I think it is invalid but if you have any remarks (especially after updating) please leave a comment and I will consider reopening this ticket.

Version 0, edited 6 years ago by Jakub Ś (next)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy