Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11841 closed Bug (invalid)

Attributes get lost after drop a anchor in ckeditor (chrome)

Reported by: vinit Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When we drop a link in ckeditor all attributes get lost except href in chrome.

Attachments (2)

firefox.png (101.9 KB) - added by vinit 6 years ago.
firefox
chorme.png (102.0 KB) - added by vinit 6 years ago.
chrome

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by vinit

Summary: Attributes get lost after drop a anchor in chromeAttributes get lost after drop a anchor in ckeditor (chrome)

comment:2 Changed 6 years ago by vinit

If drag and drop a anchor tag in ckeditor and anchor tag have attribute like id class onclick etc, get lost in ckeditor except href.

Version 0, edited 6 years ago by vinit (next)

comment:3 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.3.4
  1. Drag & Drop support is to be implemented
  2. I wasn't able to reproduce this even with ACF turned on.
  3. I got opposite result - lots of garbage styles that chrome adds.

Since I didn't get even close to your result I'm closing this issue as invalid.

It is possible that this is happening due to ACF. If that is the case and you want to use all kinds of attributes for A tags please use the following configuration option: extraAllowedContent : 'a[*]'.

Changed 6 years ago by vinit

Attachment: firefox.png added

firefox

Changed 6 years ago by vinit

Attachment: chorme.png added

chrome

comment:4 Changed 6 years ago by vinit

it is working fine in firefox when we drag and drop a link or anchor tag but it's not working in chrome browser on demo site http://ckeditor.com/demo i have attached screen shot for both browser.

comment:5 Changed 6 years ago by Jakub Ś

Now I see what you mean but issue is still invalid.

You will get same result in native browser (just try below):

<ul>
	<li style="margin:0;padding:0;">
		<a href="http://google.com" class="someclass" style="margin:0;padding:15px 25px;border-bottom:none;" >Link</a>
	</li>
</ul>
<div style="margin: 20px; border:1px solid black; width:500px;" contenteditable="true">
</div>

Native D&D will be implemented soon and will handle such cases.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy