Opened 4 years ago

Closed 4 years ago

#11848 closed Bug (fixed)

IE: Unable to get property 'checkReadOnly' of undefined or null reference

Reported by: Irina Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.4.1
Component: General Version: 4.3
Keywords: IBM IE Cc: Satya Minnekanti, Christophe Guillou

Description

  1. Open ajax sample
  2. Open console tab in developer tools and paste:
    CKEDITOR.instances.editor1.insertElement( CKEDITOR.instances.editor1.document.createElement( 'hr' ) );
    

Error: Unable to get property 'checkReadOnly' of undefined or null reference

This can be reproduced only in IE since CKEditor 4.3

Change History (7)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 4.3

Problem can be reproduced from CKEditor 4.3 in IE8-11.

Error: Unable to get property 'checkReadOnly' of undefined or null reference
URI: editable.js
Line: 299

comment:2 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.1

comment:3 Changed 4 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:4 Changed 4 years ago by Marek Lewandowski

Could not reproduce it with IE11@Win8.1 Reproduced with IE8@Win7, IE10@Win7

Also it's worth noting that error occures only during the first attempt, after that it does work as expected.

Version 0, edited 4 years ago by Marek Lewandowski (next)

comment:5 Changed 4 years ago by Marek Lewandowski

Status: assignedreview

Pushed to t/11848 at dev and t/11848 at tests.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I force pushed both branches. What was missing:

  1. The test did not fail when executed on master@dev so it did not verify that the patch fixes anything.
  2. Comments. There was no mentioning this ticket.

I fixed both things.

comment:7 Changed 4 years ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

That's odd because this TC was not passing vs both 4.4 and master in IE8@Win7. But it's good idea to switch focus to other element before testing.

Fixed with git:7b46adb119 (merged to master) at dev and 262f808c7f (merged to master) at tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy