Opened 5 years ago

Closed 5 years ago

#11995 closed Bug (invalid)

sharedSpace plugin displays a toolbar for inline editors before any editor is focused

Reported by: Shaun Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Problem:

When using inline editors and the sharedSpace plugin, the toolbar for the first editor is placed in the shared space on page load before the editor is focused.

The toolbars in the shared space should be hidden on initialization until an editor is focused.

To reproduce:

  1. Enable the sharedspace plugin
  2. Add multiple inline editors
  3. View page

Test case: http://envysphere.com/bugs/ckeditor/shared-space-20140522/

Change History (4)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

The sharedspace plugin imitates that there's only one toolbar for all editors. If it's hidden when none of the editors has focus then the imitation will be poor and also, the toolbar container will be changing height.

Additionally you wrote only about first focus. And what if you focus editor and then blur it? The situation is very the same as right after initialization.

Why do you want to hide toolbar before editor is focused?

comment:2 Changed 5 years ago by Piotrek Koszuliński

Version: 4.4.1

comment:3 Changed 5 years ago by Shaun

The sharedspace plugin imitates that there's only one toolbar for all editors. If it's hidden when none of the editors has focus then the imitation will be poor

Perhaps if the entire page is editable, I could see your point. But, when there are many different types of editable content on a page, and not all of them being an instance of CKEditor, the always-visible toolbar just creates confusion for our end users.

The functionality we seek is no different from the default inline editor toolbar. It only appears when the editable element is focused and then disappears when the editable element loses focus.


and also, the toolbar container will be changing height.

That is irrelevant to this particular issue. However, in our platform, the toolbar is a single line for all editor instances.


Additionally you wrote only about first focus. And what if you focus editor and then blur it? The situation is very the same as right after initialization.

This can be prevented by binding to the editor blur event and hiding the toolbar manually.

Version 0, edited 5 years ago by Shaun (next)

comment:4 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

Plugin's behaviour is limited and that's fine. There are unlimited possible variations and we can't have options for all of them, because that affects code size. Therefore, we're picking options which we implement very carefully now and if there's no common interest in having one, it will not be included. So, I could confirm your request as a new feature request, because it's valid from that POV, but it's unlikely that we'll work on it. We could include it if it was proposed as a pull request on GitHub, but it would depend on the amount of code it needs and the profits for users from having.

The reasonable way of proceeding in such case is forking our sharedspace plugin. This is open source, code is pretty simple, so you should be able to achieve the result you want. At the end you can add your plugin to the Addons repository so other developers can find and easily install it.

I'm closing this ticket because it was reported as a bug what's invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy