Opened 4 years ago

Closed 4 years ago

#13463 closed Bug (invalid)

Testing Instructions Out Of Date

Reported by: bmulholland Owned by:
Priority: Normal Milestone:
Component: Documentation & Samples Version:
Keywords: Cc:

Description

I'm trying to set everything up so I can submit a patch. It looks like the documentation on how to get the test setup running is out of date: http://docs.ckeditor.com/#!/guide/dev_tests

Installing benderjs does not provide bender. benderjs-cli does.

There also seems to be another dependency that I haven't managed to find yet, because after installing that package I get "Error: Cannot find module 'wrappy'" when trying to run bender.

Change History (7)

comment:1 Changed 4 years ago by bmulholland

Okay, I'm having to manually install packages one by one. Run bender, get "Cannot find module", run npm install <module>, repeat.

In general the setup and/or instructions seems pretty broken. I'd love to contribute a patch, but I can't justify all the time this is taking.

comment:2 Changed 4 years ago by Piotrek Koszuliński

We're sorry for that. The article is already updated on https://github.com/ckeditor/ckeditor-docs/tree/master/guides/dev/tests but we haven't yet published it. Do the new instructions work?

comment:3 Changed 4 years ago by Piotrek Koszuliński

Status: newpending

comment:4 Changed 4 years ago by bmulholland

Thanks Reinmar, glad to see that the updated instructions suggest installing benderjs-cli. I've done that. I did continue to run into the error I mentioned above - bender produced "Cannot find module '<module>'" - with the new instructions. Eventually, I removed the local node_modules/ and ran an npm install again, which fixed the problem. Before removing that directory, npm install didn't help. I wonder if there's an issue where if you clone the repo and npm install before installing benderjs, it won't install the right packages for bender and never picks up that it should?

The testing instructions on their own mention to install bender before cloning the repo, so they wouldn't have that issue. However, I was following the Contributing Code directions: https://github.com/ckeditor/ckeditor-docs/tree/master/guides/dev/contributing_code. Those link to the testing instructions only after cloning and running npm install, so if you started with that doc you'd encounter the issue I did.

Perhaps it would help to do an update of the Contributing Code document to reflect the completeness of the Testing documentation? Or merging the two together, since you should be running tests to contribute code anyway :)

Once I fixed the issue with the node installation, I was able to start bender and successfully run the tests.

Thanks again :)

comment:5 Changed 4 years ago by Tade0

bmulholland, I've done the installation in this order:

  1. Clone repo.
  2. Install grunt.
  3. npm install
  4. Install bender.

and failed to reproduce the issue you mentioned. If this is the same procedure you've been following, perhaps the problem lies somewhere else?

Would you mind sharing the details described below? -Your operating system -Node.js version -npm version

Version 0, edited 4 years ago by Tade0 (next)

comment:6 Changed 4 years ago by bmulholland

Oh weird. Then it may have been a one-off error.

I'm on:

  1. OSX 10.10.3
  2. node v0.12.5
  3. npm 2.11.3

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

OK, we had another guy testing it and it worked fine. So I'm closing this ticket. But of course, if anyone will have any problems, we'll investigate the case further.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy