Opened 4 years ago

Closed 3 years ago

#13734 closed Bug (invalid)

Method not found

Reported by: tobi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

First i dowloaded CKEditor with the following settings:

  1. Choose preset: Basic
  2. Select your plugins and skin:

-FontSize and Family -Basic Styles -Editor Toolbar -Enter Key -Escape HTML Entities -IFrame Editing Area -IndentList -Link -List -Undo -... followed by the plugins required by other plugins

As skin i picked "Flat".

  1. Finalize and download:

Editors language is English and German.

Then i downloaded first the Optimezed version and put it in my web projekt. I builded everything and reloaded and got this error:

"Error Parsing /xhtml/include/vdbw/edit.xhtml: Error Traced[line: 135] The element type "textarea" must be terminated by the matching end-tag "</textarea>"."

After i saw this, i commented the scipt block out where CKEDITOR.replace('mytextareaId') is called and typed in my Firebug Console CKEDITOR.replace('mytextareaId'). I got

TypeError: c[a] is undefined
a);var c=this,d=function(){c[a].dir=c.rtl[a]?"rtl":"ltr";b{a,c[a])};this[a]?d()...

So i thought i try the Source code, to see and fix the bug(if its my fault) or to better report. If i tried it with the Source code firebug told me CKEDITOR.replace is not a function.

Expected result

To see the CKEditor.

Actual result

Error

Other details (browser, OS, CKEditor version, installed plugins)

Firefox 40.0.3, Windows 7 Professional, CKEditor 4,

Plugins: -FontSize and Family -Basic Styles -Editor Toolbar -Enter Key -Escape HTML Entities -IFrame Editing Area -IndentList -Link -List -Undo -Dialog -Dialog User Interface -Fake Objects -Floating Panel -Indent/Outdent -List Block -Panel -Rich Combo -UIButton

Attachments (8)

ckeditor_optimized_error.PNG (7.9 KB) - added by tobi 4 years ago.
ckeditor_optimized_js.PNG (179.8 KB) - added by tobi 4 years ago.
ckeditor_settings_1.PNG (66.2 KB) - added by tobi 4 years ago.
ckeditor_settings_2.PNG (60.9 KB) - added by tobi 4 years ago.
ckeditor_source_error.PNG (17.2 KB) - added by tobi 4 years ago.
ckeditor_source_js.PNG (93.7 KB) - added by tobi 4 years ago.
build-config.js (1.6 KB) - added by tobi 4 years ago.
test_ckeditor.xhtml (762 bytes) - added by tobi 4 years ago.

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by tobi

Changed 4 years ago by tobi

Attachment: ckeditor_optimized_js.PNG added

Changed 4 years ago by tobi

Attachment: ckeditor_settings_1.PNG added

Changed 4 years ago by tobi

Attachment: ckeditor_settings_2.PNG added

Changed 4 years ago by tobi

Attachment: ckeditor_source_error.PNG added

Changed 4 years ago by tobi

Attachment: ckeditor_source_js.PNG added

comment:1 Changed 4 years ago by Jakub Ś

Status: newpending
  1. Please attach you build-config.js. I will try the same build as you did.
  2. Please attach your xhtm file where CKEditor is used
  3. Message CKEDITOR.replace is not a function; please make sure that ckeditor.js script is included into your xhtml
  4. Please note that you got error "The element type "textarea" must be terminated by the matching end-tag "</textarea>"." which means that you are missing closing tag for textarea. Have you corrected this issue (added closing tag)?

Changed 4 years ago by tobi

Attachment: build-config.js added

Changed 4 years ago by tobi

Attachment: test_ckeditor.xhtml added

comment:2 Changed 4 years ago by tobi

  1. and 2. is attached.
  1. in attachment ckeditor_source_js you can see that the js is loaded
  1. i deleted the comment in the script area so i see now a white site with the " c[a] is undefined" error in my console.
Version 0, edited 4 years ago by tobi (next)

comment:3 in reply to:  1 Changed 4 years ago by tobi

  1. and 2. is attached.
  1. in attachment ckeditor_source_js you can see that the js is loaded
  1. i deleted the comment in the script area so i see now a white site with the " c[a] is undefined" error in my console.

Replying to j.swiderski:

  1. Please attach you build-config.js. I will try the same build as you did.
  2. Please attach your xhtm file where CKEditor is used
  3. Message CKEDITOR.replace is not a function; please make sure that ckeditor.js script is included into your xhtml
  4. Please note that you got error "The element type "textarea" must be terminated by the matching end-tag "</textarea>"." which means that you are missing closing tag for textarea. Have you corrected this issue (added closing tag)?

comment:4 Changed 4 years ago by Jakub Ś

Version: 4.5.3

I have checked the builds (without JSF) and they work as expected.

First thing that comes to my mind is below:

<h:head>
<h:outputScript library="ckeditor" name="ckeditor.js" />
</h:head>

Are you sure file is inserted with correct path?
Are you perhaps getting any 404 (in Firebug Net tab)?
What is the generated HTML for that page?


If everything is ok with path, please tell me which implementation and version of JSF you use. It would be however better if you could send me your sample application for testing. I could check same thing as you are working with.

comment:5 Changed 4 years ago by tobi

Ok i have found 404 for config.js, de.js & style.js.

I tried it now with "<script src="resources/ckeditor/ckeditor.js" type="text/javascript"></script>" to load the ckeditor.js and everything works fine now. Seems like its not searching the other files relative to itself, but to the given path(if i use the jsf tag i think it uses the name attribute).

Thanks a lot for your help.

comment:6 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy