Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13780 closed Bug (invalid)

language not UTF-8

Reported by: Tomasz Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: tjeziorski@…

Description

Steps to reproduce

  1. go to http://ckeditor.com/demo#localization
  2. switch language to Turkish
  3. paste Turkish text "aşağıdaki Türkiye'nin" into editor
  4. switch to html view which is "Kaynak"
  5. you will see this text "<p>aşağıdaki T&uuml;rkiye&#39;nin</p>"

Expected result

i would assume it should be <p>aşağıdaki Türkiye'nin<p>

Actual result

<p>aşağıdaki T&uuml;rkiye&#39;nin</p>"

Other details (browser, OS, CKEditor version, installed plugins)

i'm using IE 9.

Change History (7)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.3

comment:2 Changed 4 years ago by Tomasz

hi, i must be doing something wrong as when it looks like my language is set to "tr" but still getting this issues.

below are my settings. could you please take a look at them and point me into right direction?

<script type="text/javascript"><![CDATA[ window.CKEDITOR_BASEPATH='../../ckeditor/'; ]]></script> <script type="text/javascript" src="../../ckeditor/ckeditor.js?t=B37D54V"></script> <script type="text/javascript"><![CDATA[ CKEDITOR.replace('editor_html', {"entities":"true","filebrowserFlashBrowseUrl":"..\/..\/ckfinder\/ckfinder.html?type=Flash","entities_latin":"false","entities_turkish":"true","width":"100%","entities_processNumerical":"false","extraCss":"body{font-family:Arial, serif;font-size:17px}","language":"tr","pasteFromWordRemoveFontStyles":"false","filebrowserImageUploadUrl":"\/pcsauttr\/ckfinder\/core\/connector\/java\/connector.java?command=QuickUpload&type=Images","filebrowserUploadUrl":"\/pcsauttr\/ckfinder\/core\/connector\/java\/connector.java?command=QuickUpload&type=Files","height":"500","filebrowserFlashUploadUrl":"\/pcsauttr\/ckfinder\/core\/connector\/java\/connector.java?command=QuickUpload&type=Flash","pasteFromWordRemoveStyles":"false","extraPlugins":"pastefromword,clipboard,dialog,dialogui","filebrowserImageBrowseUrl":"..\/..\/ckfinder\/ckfinder.html?type=Images","filebrowserBrowseUrl":"..\/..\/ckfinder\/ckfinder.html","toolbar":[['Source','Preview'],['Cut','Copy','Paste','PasteText','PasteFromWord','-','Undo','Redo'],['Find','Replace','-','SelectAll','-','SpellChecker', 'Scayt'],['Bold','Italic','Underline','Strike','Subscript','Superscript','-','RemoveFormat'],[ 'NumberedList','BulletedList','-','Outdent','Indent','-','Blockquote','CreateDiv','-','JustifyLeft','JustifyCenter','JustifyRight','JustifyBlock','-','BidiLtr','BidiRtl' ],[ 'Link','Unlink','Anchor' ],['Image','Table','HorizontalRule','SpecialChar','PageBreak','Iframe'],['Styles','Format','Font','FontSize'],['TextColor','BGColor']],"skin":"kama"}); ]]></script>

comment:3 Changed 4 years ago by Tomasz

Cc: tjeziorski@… added

comment:4 Changed 4 years ago by Jakub Ś

hi, i must be doing something wrong

Yep. I have to ld you to set entities to false while you have them set to true. Remove all the turkish, latin, and numerical properties for entities and use entities:false. That way you will not see any entities.

comment:5 Changed 4 years ago by Tomasz

Thanks a lot for such a quick response. I appreciate that.

I've followed your instructions and now object looks like this:

<script type="text/javascript"><![CDATA[ CKEDITOR.replace('editor_html', {"filebrowserFlashBrowseUrl":"..\/..\/ckfinder\/ckfinder.html?type=Flash","entities":"false","filebrowserUploadUrl":"\/pcsauttr\/ckfinder\/core\/connector\/java\/connector.java?command=QuickUpload&type=Files","width":"100%","height":"500","filebrowserFlashUploadUrl":"\/pcsauttr\/ckfinder\/core\/connector\/java\/connector.java?command=QuickUpload&type=Flash","pasteFromWordRemoveStyles":"true","extraPlugins":"pastefromword,clipboard,dialog,dialogui","extraCss":"body{font-family:Arial, serif;font-size:17px}","filebrowserImageBrowseUrl":"..\/..\/ckfinder\/ckfinder.html?type=Images","language":"tr","filebrowserBrowseUrl":"..\/..\/ckfinder\/ckfinder.html","toolbar":[['Source','Preview'],['Cut','Copy','Paste','PasteText','PasteFromWord','-','Undo','Redo'],['Find','Replace','-','SelectAll','-','SpellChecker', 'Scayt'],['Bold','Italic','Underline','Strike','Subscript','Superscript','-','RemoveFormat'],[ 'NumberedList','BulletedList','-','Outdent','Indent','-','Blockquote','CreateDiv','-','JustifyLeft','JustifyCenter','JustifyRight','JustifyBlock','-','BidiLtr','BidiRtl' ],[ 'Link','Unlink','Anchor' ],['Image','Table','HorizontalRule','SpecialChar','PageBreak','Iframe'],['Styles','Format','Font','FontSize'],['TextColor','BGColor']],"pasteFromWordRemoveFontStyles":"false","skin":"kama","filebrowserImageUploadUrl":"\/pcsauttr\/ckfinder\/core\/connector\/java\/connector.java?command=QuickUpload&type=Images"}); ]]></script>

I think we are getting closer as pasting this text " ilçelerinde ağır kayıplar bildirilmiştir " produces this html values: " <p>il&ccedil;elerinde ağır kayıplar bildirilmiştir</p> "

First word doesn't look right. Is there anything else I need to set?

comment:6 Changed 4 years ago by Jakub Ś

I cannot reproduce that. I have used entities:false plus I'm using UTF-8 and it is enough for me.

Perhaps you are not using UTF-8 after all or have something else that changes non-latin characters to entities.

comment:7 Changed 4 years ago by Mona sinha

In Firefox 41.0.1, you can paste from menu and describe format or source where you paste from, then its work. Use Unicode editor. By http://monasinha.com

Version 0, edited 4 years ago by Mona sinha (next)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy