Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13910 closed Bug (fixed)

[Webkit/Blink] Errors in test /tests/plugins/contextmenu/contextmenu

Reported by: Marek Lewandowski Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.5.5
Component: UI : Context Menu Version: 4.5.5
Keywords: Cc:

Description

There's a failing test. We need to investigate what's wrong with it.

Change History (3)

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by Olek Nowodziński

Component: GeneralUI : Context Menu
Owner: set to Olek Nowodziński
Status: confirmedreview
Summary: Failing test in /tests/plugins/contextmenu/contextmenu[Webkit/Blink] Errors in test /tests/plugins/contextmenu/contextmenu
  1. This is a Webkit/Blink issue (so in Chrome, Safari, etc.).
  2. First of all, this test passes but there are errors thrown in the console.
  3. The errors come from https://github.com/ckeditor/ckeditor-dev/blob/12175d66662899bdff0ef79f23fadf2a7a0eac93/plugins/clipboard/plugin.js#L517.
  4. This an old piece of code https://github.com/ckeditor/ckeditor-dev/blame/12175d66662899bdff0ef79f23fadf2a7a0eac93/plugins/clipboard/plugin.js#L517.
  5. It looks like we missed those errors in previous testing phases and/or something has changed in web browsers. Tried bisect but to no avail.

A fix pushed to branch:t/13910.

comment:3 Changed 4 years ago by Marek Lewandowski

Resolution: fixed
Status: reviewclosed

Fair enough, pushed to master at dev.

Version 0, edited 4 years ago by Marek Lewandowski (next)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy