Opened 3 years ago

Closed 2 years ago

#14819 closed Bug (fixed)

[Edge] Multiple unit tests failing

Reported by: kkrzton Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

After updating Edge browser from version 25 to 38 (Edge: 38.14393; EdgeHTML: 14.14393), there are multiple unit tests failing (see attached screenshot).

This is a group task for failing tests.

Attachments (1)

Screen Shot 2016-08-23 at 14.25.34.png (15.8 KB) - added by kkrzton 3 years ago.

Download all attachments as: .zip

Change History (13)

Changed 3 years ago by kkrzton

comment:1 Changed 3 years ago by kkrzton

Status: newconfirmed

comment:2 Changed 3 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedassigned

comment:3 Changed 3 years ago by kkrzton

TCs containing failing tests:

  • tests/core/config/inline (1)
  • tests/core/dom/documentfragment (1)
  • tests/core/editable/domfix2 (1)
  • tests/core/editable/wysiwyg (1)
  • tests/core/editor/title (BROKEN)
  • tests/core/filter/editor (1)
  • tests/core/selection/editor (1)
  • tests/core/selection/fake (1)
  • tests/plugins/autoembed/autoembednotifications (2)
  • tests/plugins/codesnippet/editing (1)
  • tests/plugins/floatingspace/floatingspace (1)
  • tests/plugins/image/image (1)
  • tests/plugins/image2/acf (2)
  • tests/plugins/image2/editing (2)
  • tests/plugins/image2/justify (1)
  • tests/plugins/image2/link (1)
  • tests/plugins/mathjax/mathjax (3)
  • tests/plugins/mathjax/mathjax-mock (2)
  • tests/plugins/pastefromword/pastefromword (1)
  • tests/plugins/placeholder/dialog (1)
  • tests/plugins/sourcearea/source (1)
  • tests/plugins/uploadimage/uploadimage (3)
  • tests/plugins/widget/contextmenu (1)
  • tests/plugins/widget/widgetselection (2)
  • tests/tickets/11500/1 (1)

Total of 34 tests failing.

The best approach seems to be resolve core issues first because they may be the cause of other tests (Plugins and Tickets group) failing. Also we should keep in mind that some failing tests may be the result of IE/Edge workarounds applied earlier (as Edge may have improved, the workarounds may no longer be needed).

Last edited 3 years ago by kkrzton (previous) (diff)

comment:4 Changed 3 years ago by kkrzton

tests/core/dom/documentfragment (1):

Test failing because of this strange bug: https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/8619646/

comment:5 Changed 3 years ago by kkrzton

Apart from the test mentioned in the above comment (tests/core/dom/documentfragment), all failing tests from Core group are the result of lack of support for setActive (https://github.com/ckeditor/ckeditor-dev/blob/master/core/editable.js#L80) in newest Edge version.

comment:6 Changed 3 years ago by kkrzton

After using focus instead of setActive (https://github.com/cksource/ckeditor-dev/commit/3ec9ce227243b5cfb3249e096329eebfb9f2cf3c) in Edge, tests still failing:

  • tests/core/dom/documentfragment (1) - see comment:4
  • tests/core/htmldataprocessor (1) - somehow unstable, the change does not affect it, sometimes fails with:
Expected: <p>x<a data-cke-saved-name="foo" name="foo"></a>x</p> (string)
Actual:   <p>x<a name="foo" data-cke-saved-name="foo"></a>x</p> (string)
  • tests/plugins/codesnippet/editing (1)
  • tests/plugins/image2/acf (2)
  • tests/plugins/image2/editing (2)
  • tests/plugins/image2/justify (1)
  • tests/plugins/image2/link (1)
  • tests/plugins/mathjax/mathjax (5)
  • tests/plugins/placeholder/dialog (1)
  • tests/plugins/widget/contextmenu (1)
  • tests/plugins/widget/widgetselection (2)

comment:7 Changed 3 years ago by kkrzton

Unfortunately using focus instead of setActive causes the editor to scroll (the reason why setActive was used). While the setActive is no longer supported, the only reasonable solution seems to be applying another workaround.

Steps to check if editor is scrolling on focus:

  1. Go to plugins/divarea/samples/divarea.html.
  2. Run CKEDITOR.instances.editor1.editable().find('table').getItem(0).scrollIntoView() in the console.
  3. Run CKEDITOR.instances.editor1.focus() in the console.

To check if editor was focused use document.activeElement.

Version 0, edited 3 years ago by kkrzton (next)

comment:8 Changed 3 years ago by kkrzton

Created another task #14826. It seems this issue may be the cause of all remaining failing unit tests (except the mathjax tests - tests/plugins/mathjax/mathjax):

  • tests/plugins/image2/acf
  • tests/plugins/image2/justify
  • tests/plugins/widget/widgetselection
  • tests/plugins/codesnippet/editing
  • tests/plugins/image2/editing
  • tests/plugins/image2/link
  • tests/plugins/placeholder/dialog
  • tests/plugins/widget/contextmenu
Last edited 3 years ago by kkrzton (previous) (diff)

comment:9 Changed 3 years ago by kkrzton

To sum up, there are two issues which are the cause of the most tests failing and should be fixed: #14825 and #14826.

Apart from that:

comment:10 Changed 3 years ago by kkrzton

Owner: kkrzton deleted
Status: assignednew

comment:11 Changed 3 years ago by kkrzton

Status: newconfirmed

comment:12 Changed 2 years ago by kkrzton

Resolution: fixed
Status: confirmedclosed

Both #14825 and #14826 were fixed. All unit tests on Edge are green.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy