Opened 4 years ago

Last modified 3 years ago

#16865 confirmed Bug

Fonts setting should not be toggling options.

Reported by: Ron Yu Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 4.0
Keywords: Cc:

Description

Steps to reproduce

  1. Change the font size for the first time it works correctly.
  2. But if select the same font size again, it will revert back to the original font size. The same for font style.
  3. This behavior doesn't conform to other main editors, and could bring problems.

Expected result

Please prevent revert font back to original font if select same font again.

Actual result

Resetting the font to original font if select font again.

Other details (browser, OS, CKEditor version, installed plugins)

Change History (6)

comment:1 Changed 4 years ago by Ron Yu

Besides inconformity to user habit, below is a known problem case.

  • When I have some existing text and I paste additional paragraphs after it, now selecting one font and style for all text only works the second time, because for the first selecting it just resets the previous text to default, the pasted text remains unchanged.

comment:2 Changed 4 years ago by Jakub Ś

Status: newconfirmed
Version: 4.5.04.0

It has been working like that even in CKEditor 3.x. The benefit of such approach is that you can simply click into area with a given font, select font from the list to remove that font from whole area.

The only problem which I see here, is the one you have mentioned in comment:1. We should be doing like MS Word does - when there is more than one font selected or there is "font text font" in selection, we should not auto highlight the font in dropdown.

Probably also some extra fixes will be needed to remove all nested fonts from selection and apply new one outside.

Version 0, edited 4 years ago by Jakub Ś (next)

comment:3 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

It turns out this is a duplicate of #13553

comment:4 Changed 3 years ago by Marek Lewandowski

Resolution: duplicate
Status: closedreopened

@j.swiderski these are two different issues.

Issue #13553 says about dropdown in case of selection that is has a different value at the beginning and the end of selection, e.g. two different fonts.

This issue however is related to the fact that once having given value in a dropdown, say X, if you pick X again the feature will remove the style from editor, while here OP expects the option to be preserved.


Now, the current solution means like simple bold/underline features, meaning that if you press it while being active, it will remove the style. It works, but as mentioned this behavior is not interoperable with other editors.

I agree that this change make sense for a better conformance with a common editing experience. However it's a UX change that should be delivered with a major release.

Note that this has more implications: how one should remove font size markup? It requires to add something like <unset> position in the dropdown, which is also not an ideal solution.

comment:5 Changed 3 years ago by Jakub Ś

Status: reopenedconfirmed

@m.lewandowski you are right I got too quick closing this one.

comment:6 Changed 3 years ago by Marek Lewandowski

Meanwhile I have reported [the issue in our GitHub](https://github.com/ckeditor/ckeditor-dev/issues/584) so it can be discussed there. I made it a feature request though, as it's not a bug.

Last edited 3 years ago by Marek Lewandowski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy