Opened 10 years ago

Closed 8 years ago

#3045 closed Bug (invalid)

FCK In lightbox - Menus don't show properly

Reported by: Doug Davis Owned by: Martin Kou
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I have forms that appear in a lightbox. I would like to put an FCK editor in those forms. However, when the user clicks on a menu, it is not positioned with the editor, because the iframe of the menu is a child of the body and absolutely positioned within the body.

I would like for it to be made possible to show an FCK editor within a lightbox or other div that is not absolutely positioned within the body tag, and the menus appear appropriately.

I believe it would take an option for what child element the menu iframes are children of.

Attachments (2)

fck.PNG (70.0 KB) - added by Doug Davis 10 years ago.
Wrong menu placement
3045.patch (4.5 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by Doug Davis

Attachment: fck.PNG added

Wrong menu placement

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed added
Milestone: FCKeditor 2.6.5
Type: New FeatureBug

We've prevented this bug in v3, but it's valid in current FCKeditor 2.6.5.
Click here for a try on v3.

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 10 years ago by Martin Kou

Attachment: 3045.patch added

comment:3 Changed 10 years ago by Martin Kou

For a moment I was thinking I've reproduced the bug by shrinking the window - but it wasn't. It was just the combo box accommodating to the bottom of the shrunk window.

So I actually haven't reproduced the bug here, and so I still need a page in which the bug can be reproduced. But I've already back ported the getDocumentPosition() function from v3 in the patch - v3's function is more well tested.

comment:4 Changed 10 years ago by Martin Kou

Keywords: Pending added; Confirmed removed

I'm not able to reproduce this issue, and Garry has forgotten how he was able to reproduce the bug when he marked the ticket as confirmed.

Can we have a sample page demonstrating the problem?

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6.5

This one has been mistakenly targeted to the 2.6.5.

comment:6 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

FCKeditor was retired and is no longer supported. All active development was moved to its predecessor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible.

Version 0, edited 8 years ago by Jakub Ś (next)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy