Opened 8 years ago

Closed 8 years ago

#3946 closed Bug (fixed)

Unable to hide contextmenu

Reported by: Garry Yao Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Context Menu Version:
Keywords: Confirmed Review+ Cc:

Description

Reproducing Procedures

  1. Open a context menu with a second-level sub menu;
  2. Activate the sub menu by mouse over the menu item;
  3. Now mouse move back to the first-level menu;
  4. Activate the same sub menu again;
  5. Click on the document text;
    • Actual Result: The context menu stays visible.

Attachments (2)

3946.patch (1.2 KB) - added by Tobiasz Cudnik 8 years ago.
3946_2.patch (1.9 KB) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:2 Changed 8 years ago by Tobiasz Cudnik

Keywords: IE added

Two focus handlers aren't fired in IE6 strict. Those one which un-block blur lock.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3946.patch added

comment:3 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

Issue was caused by not-working forced iframe-focus logic for IE non-quirks. This patch offers also optimization for displaying same child menu (as visible), which are now skipped. This prevents flickering issue on IE and generally reduces executed code.

comment:4 Changed 8 years ago by Garry Yao

Keywords: Review- added; IE Review? removed

IE is not the only browser affected. The patch doesn't work in Firefox.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3946_2.patch added

comment:5 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

Last minute fix broken focus event in FF. Reverting missing code.

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:7 Changed 8 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3908].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy