Opened 8 years ago

Closed 8 years ago

#4118 closed Bug (fixed)

The dialog drag behaves strange (sometimes)

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Dialogs Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

Sometimes when a dialog opens, the attempt to drag it behaves strnage. The dialogs sudenly moves to the border of the document and stays sliding there, not moving to the center again.

This one is difficult to reproduce. It's random, and may depend on the browser performance and dialog download time. It happend with FF3.5.

Attachments (1)

4118.patch (1.4 KB) - added by Frederico Caldeira Knabben 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Frederico Caldeira Knabben

Attachment: 4118.patch added

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Status: newassigned

As this thing is difficult to reproduce, I can't guarantee that this patch works. But it looks logic. Much probably the issue is related to the getSize() function, which caches the wrong size (we've dealed with it in other tickets). So, I'm just forcing it to be recalculated before start dragging.

comment:2 Changed 8 years ago by Tobiasz Cudnik

We could simply add a dontCache flag to getSize() which would be true in first call (when centering) and first next call (drag) would cache dialog size. Or simpler - set updateSize to true after first call to getSize(). What do you think ?

Ticket you're referring to is #4084.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

As now we could have some tabs enlarging the dialog size when opened, maybe my approach would also help on fixing these cases too. We should have no performance impact with it. It should be safe.

comment:4 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review+ added; Review? removed

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3998].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy