Opened 10 years ago

Closed 10 years ago

#4145 closed Bug (fixed)

[IE] core/bootstrap is suspended in IE

Reported by: Garry Yao Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IE Confirmed Review+ Cc:

Description

When opening core/bootstrap.html TCs separately, IE throwing errors shows that the core scripts is not loaded or executed at the right order, which breaks the TCs.

Attachments (1)

4145.patch (4.4 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by Garry Yao

It seems that scripts loaded via appending on the DOM doesn't guarantee the execution order in IE, where the 'document.write' way always works.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: newassigned

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 4145.patch added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added

This patch guarantees the execution logic inside the CKEDITOR.loader dependencies. It may make the editor loading a bit slower in source mode, but that's the only feasible way for it. We should not have performance issues because of this though.

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [4019].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy