Opened 8 years ago

Closed 8 years ago

#4573 closed Bug (fixed)

Ignore empty paragraph doesn't work with config.enties = false;

Reported by: Matti Järvinen Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: Core : Output Data Version: 3.0.1
Keywords: Confirmed Review+ Cc:

Description

If

config.entities = false;
config.ignoreEmptyParagraph = true;

Click editor area. > Empty paragraph gets created. > Change to source view. > Paragraph exists > change back to wysiwyg.

Submit form in wysiwyg mode and the empty paragraph exists in submitted data (since paragraph ends with   character not html entity).

Attachments (1)

4573.patch (669 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by Garry Yao

Keywords: Confirmed added; htmlwriter removed
Milestone: CKEditor 3.xCKEditor 3.1

Nice catch ;)

comment:2 Changed 8 years ago by Garry Yao

Ticket Test added at : http://ckeditor.t/tt/4573/1.html.

Changed 8 years ago by Garry Yao

Attachment: 4573.patch added

comment:3 Changed 8 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [4446].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy