Ticket #4711 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

entering text after a newline within pre-tags

Reported by: flipreverse Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Enter Key Version: 3.0
Keywords: Confirmed Review+ Cc:

Description (last modified by fredck) (diff)

  1. use this piece of code:
<pre>Hello world!
Bla, bla, bla
</pre>
  1. make two or three newlines between the first and second row
  2. go to the first/second created line and type some text

The cursor jumps to the next row and the text is to be printed.

Attachments

4711.patch (556 bytes) - added by garry.yao 4 years ago.

Change History

comment:1 Changed 4 years ago by fredck

  • Keywords pre text newline removed
  • Description modified (diff)

comment:2 Changed 4 years ago by fredck

  • Keywords Confirmed added
  • Milestone changed from CKEditor 3.x to CKEditor 3.3

Confirmed. Both IE and FF present different but still weird behavior.

Changed 4 years ago by garry.yao

comment:3 Changed 4 years ago by garry.yao

  • Status changed from new to assigned
  • Keywords Review? added
  • Version set to 3.0
  • Owner set to garry.yao

<br> just works better than linefeed at least in Firefox. In IE, we probably has no way to fix it other than splitting the <pre>.

comment:4 Changed 4 years ago by alfonsoml

  • Keywords Review+ added; Review? removed

I've filed #5350 for IE8 because the problem there is quite different.

comment:5 Changed 4 years ago by Saare

#5296 may be related.

comment:6 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [5252].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy