Opened 8 years ago

Closed 6 years ago

#8736 closed Bug (fixed)

IE: Pasting a list after applying font-size to a paragraph wraps list-items in spans

Reported by: Jakub Ś Owned by:
Priority: Normal Milestone:
Component: General Version: 3.1
Keywords: IE IBM Cc: monahant@…

Description (last modified by Jakub Ś)

Steps to reproduce:

  1. Go to any sample (using IE)
  2. Copy the bullets from the attached document
  3. Write out, "Hello World"
  4. Select "Hello World" and apply a font-size of 14
  5. Place your cursor at the end of the line, (Hello World^), and press the enter key to create a new line (Element's path is showing body p span)
  6. Paste the bullets using the CTRL+V keyboard shortcut.

Result: All list items are wrapped in span-tags with font-size 14.

The issue has been reproducible from CKEditor 3.1 (In earlier versions results were not even close to the ones presented here)

NOTE:All browsers copy span to another line but only IE applies this span to inline elements or text

Attachments (2)

Item List.docx (14.3 KB) - added by Jakub Ś 8 years ago.
IE8.png (14.3 KB) - added by Jakub Ś 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 8 years ago by Jakub Ś

The same thing is happening for E.g. table or header (see attachment).

Last edited 8 years ago by Jakub Ś (previous) (diff)

Changed 8 years ago by Jakub Ś

Attachment: Item List.docx added

Changed 8 years ago by Jakub Ś

Attachment: IE8.png added

comment:3 Changed 8 years ago by Jakub Ś

Actually list items are wrapped in spans when you switch to source mode.
Before switching block element (table/heading/list) is wrapped in inline span (see IE8.png)

This causes extra problems in IE8 and IE9 when following these steps:

  1. Copy list from docx
  2. Clear editor contents with Click, CRTL+A, Backspace
  3. Type hello world, select it SHIFT+Home and apply font 14px
  4. Unselect with right arrow
  5. Paste list with CRTL+V
  6. Press Backspace

Result:
IE9 cursors jumps before getting to last list item.
IE8 last letter of last item is deleted but cursor is displayed in wrong place. Additionally after pressing backspace CRTL+A won't work.

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:5 Changed 7 years ago by Jakub Ś

The same root of the problem (pasting block into inline in IE) is applicable for other tickets: #9207, #8294, #9740. I think they all can be fixed with one patch.

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:6 Changed 7 years ago by Jakub Ś

Description: modified (diff)

comment:7 Changed 7 years ago by Jakub Ś

#9480 was marked as duplicate.

The same thing happens if you for example copy table from editor and paste it into styled paragraph.

comment:8 Changed 7 years ago by Teresa Monahan

Cc: monahant@… added
Keywords: IBM added

This has now been raised by one of our customers with the following simple usecase:

  • Copy the following into Source view and switch back to wysiwyg mode:
    <p>
    	Black text <span style="color: #ff0000">Red text</span></p>
    
    
  • Copy the text and place the cursor at the end of it: 'Black text Red text'
  • Hit enter and then paste the content.

Problem: The 2nd line of text is all red. It should be the exact same as the first line of text.

This is reproducible in all versions of IE in CKEditor 3.5.x and 3.6.x. I cannot reproduce it in CKEditor 4.

comment:9 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

Problem seems no longer reproducible in latest CKEditor 4.2. I'm marking it as fixed.

@IBM if you still wish to have this ticket fixed for CKEditor 3.x please leave a comment and i will reopen this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy