Changes between Initial Version and Version 1 of Ticket #9317, comment 22


Ignore:
Timestamp:
Jul 3, 2014, 3:11:34 PM (5 years ago)
Author:
Piotrek Koszuliński
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #9317, comment 22

    initial v1  
    77> IMHO it make sense to encapsulate this logic into separate function just for readability sake. One does not have to deal with this complexity if he's browsing/working with {{{onDomReady}}}. Function {{{resizeStartListener}}} in fact should be inside the object, I've fixed that.
    88
    9 So you can move this code to a separate function, but not to object. You don't need object, because there's no state, excep and there will be just one function with another function defined inside it. Actually - I'm wrong - there's state, but... you keep it in closure. So why not keeping everything in closure?
     9So you can move this code to a separate function, but not to object. You don't need object, because there's no state and there will be just one function with another function defined inside it. Actually - I'm wrong - there's state, but... you keep it in closure. So why not keeping everything in closure?
    1010
    1111>
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy