Opened 10 years ago

Closed 10 years ago

#9483 closed Bug (fixed)

CKE 3.x and 4.x - Menu buttons do not open in IE10

Reported by: Matt Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.6
Component: UI : Floating Panel Version: 3.4.3
Keywords: IE10 Cc:

Description (last modified by Jakub Ś)

Since IE10 with Windows8 will be released in several days (Oct 26, 2012) I tested CKEditor with it.

It seems that the menu buttons like SCAYT, Font Color and Font Background Color do not open in IE10. This can be confirmed on <http://ckeditor.com/demo>. I also checked the nightlyies, no difference.

I think the problem lies in floatpanel/plugin.js in line 217, where widthNode.document is undefined.

If I add a env.ie10Compat (in env.js) and check for that in the line mentioned above, everything works fine.

I attached a patch file with a potential fix.

Attachments (2)

Patch_to_fix_opening_of_colorpicker_in_ie10.patch (1.4 KB) - added by Matt 10 years ago.
Patch to fix opening of colorpicker in IE10
9483.patch (1.1 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by Matt

Patch to fix opening of colorpicker in IE10

comment:1 Changed 10 years ago by Jakub Ś

Description: modified (diff)
Keywords: IE10 added
Status: newconfirmed
Summary: Colorpicker does not open in IE10Menu buttons do not open in IE10
Version: 3.4.3

JS error is:
Message: Unable to get property 'body'
Line: 217
URI: ckeditor/_source/plugins/floatpanel.js

I have set version 3.4.3 because this is the first version where content area was actually loaded without errors.

If it matters till version 3.6.3 menus have popped out despite error (in wrong place)

Last edited 10 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 10 years ago by Jakub Ś

Summary: Menu buttons do not open in IE10CKE 3.x and 4.x - Menu buttons do not open in IE10

comment:3 Changed 10 years ago by Garry Yao

Component: GeneralUI : Floating Panel
Milestone: CKEditor 4.0

comment:4 Changed 10 years ago by Garry Yao

Changed 10 years ago by Garry Yao

Attachment: 9483.patch added

comment:5 Changed 10 years ago by Garry Yao

Milestone: CKEditor 4.0CKEditor 3.6.6
Owner: set to Garry Yao
Status: confirmedreview

comment:6 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: reviewclosed

As we went through the v4 testing stage with this patch, I ported it to v3 with only a fast check.

Fixed with [7661].

comment:7 Changed 10 years ago by Jakub Ś

Resolution: fixed
Status: closedreopened

comment:8 Changed 10 years ago by Jakub Ś

Status: reopenedconfirmed

CKEditor v4 works; both git and release versions work.

CKEditor v3 it doesn't work here http://rev.ckeditor.com/ckeditor/trunk/7664/_samples/ but when I try my local SVN version everything works as expected. Perhaps only release code is affected.

The same thing happens with #9378.

Version 0, edited 10 years ago by Jakub Ś (next)

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: confirmedclosed

Fixed with [7673].

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy