Opened 7 years ago

Closed 7 years ago

#9484 closed Bug (fixed)

Arabic text issue in Editor

Reported by: mansoor Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version:
Keywords: Cc:

Description

Hi, When i typed the Arabic text in the ckeditor unfortunataley its display wrong text .

Arbic text which I typed in editor : المملكة الموافق it display : لنن ملكق لننوافق

In content.css I have assigend a our custom font however its works fine in MS-Word , but I dont know why its happend .! in ckeditor. Find the attached screenshot you will get idea.

Highly appreciated for given reply.

Thanks & Regards, Mansoor

Attachments (7)

arabictextissueineditor.zip (39.8 KB) - added by mansoor 7 years ago.
config.js (331 bytes) - added by mansoor 7 years ago.
config.js
contents.css (613 bytes) - added by mansoor 7 years ago.
contents.css
arabic text.JPG (111.3 KB) - added by mansoor 7 years ago.
screenshot
Test_UC1l.ascx (53.2 KB) - added by mansoor 7 years ago.
aspx file that using CKEditor
word_table.docx (10.3 KB) - added by mansoor 7 years ago.
MS-word table content
tablewithout_bgcolor.JPG (40.0 KB) - added by mansoor 7 years ago.
ckeditor_table cell background color

Download all attachments as: .zip

Change History (20)

Changed 7 years ago by mansoor

Attachment: arabictextissueineditor.zip added

comment:1 Changed 7 years ago by Jakub Ś

Status: newpending

I have tried your TC but didn't get any problems.

Could you tell me:

  1. In which browsers does it happen, perhaps all?
  2. What is the exact TC? From your description and screen it looks like you type letters in Source mode, you switch to WYSIWYG and letters change. Is that correct or you perhaps save data somewhere in the meantime?
  3. Could you provide screencast of this problem?
  4. What language is set in editor and what other settings have you used. Could you attach config.js?

comment:2 Changed 7 years ago by mansoor

Hi ,

Thanks for ur response,

  1. I am using IE 8 browser.
  2. In editor i am typing arabic text " المه" but it converts at the same time " اننه" . when i check the source mode its display correct text,and didn't saved anywhere.
  3. am sending you screenshot ,you will get idea.
  4. am sending config.js file and below is the statement which i set to ckeditor

CKEditorControl1.ContentsLangDirection = CKEditor.NET.contentsLangDirections.Rtl;

Last edited 7 years ago by Jakub Ś (previous) (diff)

Changed 7 years ago by mansoor

Attachment: config.js added

config.js

Changed 7 years ago by mansoor

Attachment: contents.css added

contents.css

Changed 7 years ago by mansoor

Attachment: arabic text.JPG added

screenshot

comment:3 Changed 7 years ago by Jakub Ś

Component: GeneralServer : ASP.Net

Ok so you are using CKEditor for ASP.NET. This is very important note; please mention such "details" in the future.

  1. Could you attach aspx page that you are using to display CKEditor.
  2. Could you also provide setting that you have used for control like the one you have mentioned - CKEditorControl1.ContentsLangDirection = CKEditor.NET.contentsLangDirections.Rtl;

comment:4 Changed 7 years ago by mansoor

As per above request,

  1. find the attached aspx page that i am using CKEditor.
  2. the setting which i provide below ,this is i mention in page_load () thats it.
Version 0, edited 7 years ago by mansoor (next)

Changed 7 years ago by mansoor

Attachment: Test_UC1l.ascx added

aspx file that using CKEditor

comment:5 Changed 7 years ago by Jakub Ś

Hi sorry for the late response.

I have check your file on my local server but didn’t get any problems. Letters were not changed.
I had to do a lot of code removing because you haven't provided Test_UC1l.ascx.cs or something more reduced that didn't require this file and where error was also reproducible.

This looks to me like encoding issue on your server or in your app as I'm not getting (neither my colleagues) this sort of problems.

Another option might that perhaps one of these extra webcontrols or perhaps some extra JavaScript you are using is causing this. I haven't seen them calling CKEditor code and I haven't seen any extra scripts so this might be a dead end but it is worth checking if such problem exists without any add-ons that might conflict with CKEditor.

Could you please check these two things and leave a reply?

comment:6 Changed 7 years ago by mansoor

Hi,

I have noticed one issue in CkEditor,that i copied table from MS-word and paste in ckeditor,unfortunately the table cell background color is not copied in ckeditor its only copied table and content .

Any idea?

Regards, MAK..

comment:7 Changed 7 years ago by Jakub Ś

Most likely you have forgotten about setting this in config.js

config.pasteFromWordRemoveFontStyles=false;
config.pasteFromWordRemoveStyles=false;

@makckeditor what about original problem? Is it still reproducible or you have managed to solved it? If so what was the problem?

comment:8 Changed 7 years ago by mansoor

Hi,

Find the attached documents , you will get idea.. I try to copied the table from Word after paste it in ckeditor but the table header background color is not copied ? that is problem.

Even i put the above lines of code in config.js ,but these is not effected.

Regards MAK..!

Changed 7 years ago by mansoor

Attachment: word_table.docx added

MS-word table content

Changed 7 years ago by mansoor

Attachment: tablewithout_bgcolor.JPG added

ckeditor_table cell background color

comment:9 Changed 7 years ago by Jakub Ś

What about original problem is it still reproducible or not? Please leave a comment about this (is it ok no and what was wrong) as this is what original TC was about. Thank you.

comment:10 Changed 7 years ago by mansoor

I am going to find out excatly solution but,right now i have noticed this problem facing only in IE -6 browser in windows XP and google crome also.

I dont know what is the problem ?

Regards Mak..!

comment:11 Changed 7 years ago by Jakub Ś

I have just checked your issue and didn't get any problems again.

Try adding below two options in config.js

config.pasteFromWordRemoveFontStyles=false;
config.pasteFromWordRemoveStyles=false;

or if you are using CKEditor for ASP.NET add these options in CKEditor control -

<CKEditor:CKEditorControl ID="CKEditor1" ... PasteFromWordRemoveFontStyles="False" PasteFromWordRemoveStyles="False">

Please try also refreshing the cache (crtl+F5 is not enough).

comment:12 Changed 7 years ago by mansoor

Hi,

As you said in the above settings i put the PasteFromWordRemoveFontStyles="False" PasteFromWordRemoveStyles="False" and refreshing the cache.. but it is not working.

Background table cell color is not diplay in ckeditor. what could be the problem ?

comment:13 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

@makckeditor - yes you are right there is a problem with ASP.NET control and PasteFromWordRemoveStyles="False" used in control. I have reported it here #9616.

Workaround is to use in ckeditor/config.js

config.pasteFromWordRemoveFontStyles=false;
config.pasteFromWordRemoveStyles=false;

Don't forget to use latest version of CKEditor.


Because I was not able (and neither of my colleagues) to reproduce the original TC and I didn't receive any 100% effective steps to reproduce, I'm closing this issue as invalid. If you are able prepare such steps (for original TC) please leave a comment.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy