Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9594 closed Bug (fixed)

Cannot tab past CKEditor when it is in read only mode

Reported by: Teresa Monahan Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.0.1
Component: Core : Read-only Version: 3.6
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

  • Open _samples/readonly.html.
  • Click the 'Make it read-only' button and then tab through the page until the editor gets focus.
  • Tab again to move focus to the button below the editor.

Problem: It is not possible to Tab / Shift+Tab once the read only editor has focus.

This is also an issue in CKEditor 4.0 if the editor contains some focusable element. In this case, pressing tab when the editor has focus, moves focus to the first focusable element inside the editor contents and then it is not possible to Tab / Shift+Tab.

Change History (9)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed
Version: 3.6.23.6

Reproducible from CKEditor 3.6 rev. [6904] (when readonly was intrduced).

CKEditor 4.x needs focusable element like link to get error reproduced.

Version 0, edited 7 years ago by Jakub Ś (next)

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Read-only
Milestone: CKEditor 3.6.6

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedreview

Pushed fix on t/9594@cksource.

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.6CKEditor 4.0.1

comment:5 Changed 7 years ago by Olek Nowodziński

Status: reviewreview_passed

Pity we cannot simulate real DOM events for testing purposes.

comment:6 Changed 7 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Masterised git:425410c.

comment:7 Changed 7 years ago by Frederico Caldeira Knabben

In v3, this has been fixed with [7681].

comment:8 in reply to:  7 Changed 7 years ago by Satya Minnekanti

Replying to fredck:

In v3, this has been fixed with [7681].

It's not properly fixed in 3.6.x as in 4.0.1

When we are navigating forward, when we press tab after reaching editor body, moving the focus to element outside editor body instead of the focussable element(link) in editor body. Also when navigating back when we press Shift + Tab after reaching focussable element(link) in editor body focus moving to element before editor body instead of editor body.

Could you please re-open the ticket and fix it in 3.6.x as the way it works in 4.0.1

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

This is a persistent difference that can't be worked-around because of the totally different DOM structures and focus strategy present in v3 and v4.

We can say that both behavior are good. The issue may be only the fact that different versions behave differently, but that's something we'll have to live with.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy