Opened 7 years ago

Closed 4 years ago

#9736 closed Bug (fixed)

[Android] Problems with text selection

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: Core : Selection Version: 3.6.5
Keywords: IBM Android Cc: Damian, Satya Minnekanti, edel_gleeson@…

Description

  • Open any CKEditor sample on an android 4 tablet.
  • Enter some text.
  • Try to highlight the text to select it.

Problem: The option to select text does not appear.

In a basic contenteditable div, the select text tool appears when you hold down on text within the div.

Attachments (8)

Android-4.2.1-stock-iframe.png (79.1 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-stock-inline-after-command.png (55.2 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-stock-inline.png (47.3 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-Firefox-iframe.png (65.1 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-chrome-iframe.png (95.3 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-chrome-iframe-handles.png (79.6 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-chrome-inline.png (84.0 KB) - added by Anna Tomanek 7 years ago.
Android-4.2.1-chrome-inline-bold-applied.png (97.7 KB) - added by Anna Tomanek 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by Jakub Ś

This issue is similar to #8648.

comment:2 Changed 7 years ago by Bago

I can confirm this using Android 4 (ICS) on Motorola Xoom.

I tested some Android ICS browser: Stock: selection works only in "inline" mode and not in iframe mode. Toolbar doesn't work. Chrome: selection works in inline and iframe, toolbar works in both. Firefox: selection works in both but toolbar doesn't work. Dolphin: everything seems broken.

When I say "toolbar doesn't work" I mean that it appears, I can click on the buttons but as soon as I "touch" a button the selection disappear and the action is not applied (eg: bold).

So, Chrome is the only browser supported by my ICS tablet to work.

comment:3 Changed 7 years ago by Jakub Ś

Keywords: Android added

comment:4 Changed 7 years ago by Anna Tomanek

Component: GeneralCore : Selection
Status: newconfirmed
Summary: Android: It is not possible to select text in the editor[Android] Problems with text selection

Tested on Samsung Galaxy S, Android 4.2.1 (Jelly Beans), CKEditor 4.0.1 samples for the Standard preset.

Stock browser, replacebycode (iframe) sample

Selection works if you touch and hold, but only one word is selected. Standard Android selection "handles" (that let you expand the selection) do not appear. It's possible to use toolbar buttons to do something with the selection (like Bold etc).

Stock browser, inline sample

Selection works, selection handles appear, it's possible to use toolbar buttons to do something with the selection. However, after an operation is performed, the handles disappear while the expanded text selection stays intact.

Firefox browser, replacebycode (iframe) sample

Selection works if you touch and hold, one word is selected and you can expand the selection by using the handles. However, when the page is subsequently scrolled, the handles stay in place and thus become out of sync with the selection (see screenshot). It is *not* possible to perform any operation on the selection, after a toolbar button (like Bold) is clicked, text becomes unselected and no change is applied.

Firefox browser, inline sample

The same as in iframe, the only difference being that the handles move correctly with page scrolling.

Version 0, edited 7 years ago by Anna Tomanek (next)

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

comment:5 Changed 7 years ago by Anna Tomanek

Chrome 18.0.1025469, replacebycode (iframe) sample

Selection works if you touch and hold, one word is selected and you can expand the selection by using the handles. However, when the page is subsequently scrolled, the handles stay in place and thus become out of sync with the selection (see screenshot). It *is* possible to perform any operation on the selection, after a toolbar button (like Bold) is clicked, text becomes unselected but a change is applied.

Chrome 18.0.1025469, inline sample

The same as in iframe, the only difference being that the handles move correctly with page scrolling.

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

Changed 7 years ago by Anna Tomanek

comment:6 Changed 6 years ago by Piotr Jasiun

I've tested selection on Android 4.4.2 with Chrome 30 everything works fine and smoothly.

comment:7 Changed 4 years ago by Szymon Kupś

Resolution: fixed
Status: confirmedclosed

Tested on Android 5.1.1 with Chrome 44 and stock browser (based on Chrome 39) and it worked fine. Android WebView since KitKat(4.4) is using Chromium, and most stock browsers are build upon that.

Still, this issue is valid for Firefox 40 on Android, so I've created: #13721.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy