Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9875 closed Bug (fixed)

Table dialog doesn't populate width correctly

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0.1
Component: Core : Tables Version: 4.0.1
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

  1. Open any sample (on dev version).
  2. Open table dialog.
  3. Reset width (default is 500).
  4. Insert table.
  5. Open table dialog to edit inserted table.
  6. Width is set '500' again.

Now repeat these steps with extraPlugins = 'dialogadvtab'. On step 6. width is correctly set to empty value.

Change History (8)

comment:1 Changed 10 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 10 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: newreview

Pushed t/9875 @dev&tests.

comment:3 Changed 10 years ago by Piotrek Koszuliński

Similar (or identical) tickets: #9478, #9560.

comment:4 Changed 10 years ago by Jakub Ś

This look like a DUP of #9478.

#9560 can be reproduced in v3 and v4 but perhaps could be fixed with one change.

comment:5 Changed 10 years ago by Piotrek Koszuliński

Let's keep this ticket, because I noticed it during running tests for 4.0.1.

One of table test for release version was failing, but on dev it's green. This happens because in full preset dialogadvtab is loaded and it somehow fixes incorrect dialog tab behaviour. I think that it overwrites incorrectly loaded default value with correct one, but I'm not sure when that happens. Anyway - patch propsed in t/9875 seems to fix this. For unclear reason empty value wasn't loaded so default was used. This was repeated in tests, so I had to fix them too.

comment:6 Changed 10 years ago by Olek Nowodziński

It feels fine for me, so R+...

On the other hand, I have a creepy feeling since this worked fine in 4.0 and we really don't know why it was broken.

comment:7 Changed 10 years ago by Piotrek Koszuliński

Status: reviewreview_passed

Nothing worked fine in 4.0. See reported tickets which I linked above.

It only worked fine when dialogadvtab plugin was loaded.

PS. You're so indecisive that I'm R+ing this by my own :>.

comment:8 Changed 10 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed with git:097a0a8

Version 0, edited 10 years ago by Piotrek Koszuliński (next)
Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy