Ticket #1052 (closed Bug: invalid)

Opened 8 years ago

Last modified 3 years ago

Semantic MediaWiki

Reported by: gabriele Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc: reinout@…, maze@…

Description

The editor has several bugs that make it not compatible with the extension Semantic Mediawiki (SMW); it doesn't recognize the relations and the attributes: it converts them into links.

The editor should manage at least:

1) SMW relation definition: [[has_relation::object|object_name]]

2) SMW attribute definition: [[attribute_name:=value]]

for the moment, it should be enough if it doesn't convert them into links.

Change History

comment:1 Changed 8 years ago by alfonsoml

  • Component changed from General to Project : MediaWiki+FCKeditor

comment:2 Changed 7 years ago by w.olchawa

#1676 has been marked as DUP

comment:3 Changed 7 years ago by w.olchawa

Sorry! Not #1676 but #1675 has been marked as DUP.

comment:4 Changed 7 years ago by evan

This syntax should only be enabled if the Semantic MediaWiki extension is installed.

comment:5 Changed 7 years ago by w.olchawa

  • Keywords Confirmed added
  • Type changed from Bug to New Feature

comment:6 Changed 7 years ago by w.olchawa

  • Type changed from New Feature to Bug

comment:7 Changed 7 years ago by ericblue76

Hi,

Is there an ETA on when FCKeditor will be compatible with the Semantic Media Wiki extension. The particular issue I'm dealing with is noted at http://mediawiki.fckeditor.net/index.php/Semantic_MediaWiki. The FCKeditor extension is really fantastic. However, I use SMW heavily throughout my wiki so I really can't use until this is addressed.

I'd be more than happy to help fix some of the incompatibility issues if somebody can point me in the right direction.

Thanks!

comment:8 Changed 7 years ago by reinouts

  • Cc reinout@… added

From what I understand: In FCKEditor.body.php, function strip(), lines 186 - 226, a number of special tags is specified that the FCKEditor parser shouldn't touch. We have to find out if this functionality can be expanded so that SMW-tags are excluded as well.

It may also be interesting to study SMW_Hooks.php in the SMW code, it contains a hook for the semantic parser (function smwfParserHook).

That's how far I got today. Disclaimer: I'm a PHP noob.

comment:9 follow-up: ↓ 10 Changed 7 years ago by neiladavies@…

Add the following code to that start of smwfParserHook in SMW_Hooks.php

if ($parser instanceof FCKeditorParser)

return true;

comment:10 in reply to: ↑ 9 Changed 6 years ago by bieshaar

Replying to neiladavies@gmail.com:

Add the following code to that start of smwfParserHook in SMW_Hooks.php

if ($parser instanceof FCKeditorParser)

return true;

SMW_Hooks.php doesn't exist in my Semantic Installation 1.3

Could you be more specific and/or does it solve the compatibility problem with Semantic and FCKeditor.

Really hoping for a solution now, 'cause both extensions are perfect for our wiki.

comment:11 Changed 6 years ago by neiladavies@…

If you don't have SMW_Hooks then your installation is wrong/corrupt/etc. It should be with the other SMW files in extensions/SemanticMediaWiki/includes

Try it and see if it solves your problems

comment:12 follow-up: ↓ 14 Changed 6 years ago by strycher

SMW 1.4.1 Instructions/Modifications:

In SMW 1.4.1 the authors have eliminated SMW_Hooks.php from the distribution, as well as two other files. The result is that the functions have moved to other files. The solution for SMW 1.4.1 is to add the lines provided above to "extensions/SemanticMediaWiki/includes/SMW_ParserExtensions.php" at approximately line 30, so that it looks like the following:

	static public function onInternalParseBeforeLinks(&$parser, &$text) {
		global $smwgStoreAnnotations, $smwgLinksInValues;

	        if ($parser instanceof FCKeditorParser)

    	            return true;

		SMWParseData::stripMagicWords($text, $parser);

Once modified, SMW properties seem to work again and FCKEditor seems to operate as well.

comment:13 Changed 6 years ago by djmaze

  • Cc maze@… added

comment:14 in reply to: ↑ 12 Changed 5 years ago by calmo

Replying to strycher:

SMW 1.4.1 Instructions/Modifications:

In SMW 1.4.1 the authors have eliminated SMW_Hooks.php from the distribution, as well as two other files. The result is that the functions have moved to other files. The solution for SMW 1.4.1 is to add the lines provided above to "extensions/SemanticMediaWiki/includes/SMW_ParserExtensions.php" at approximately line 30, so that it looks like the following:

	static public function onInternalParseBeforeLinks(&$parser, &$text) {
		global $smwgStoreAnnotations, $smwgLinksInValues;

	        if ($parser instanceof FCKeditorParser)

    	            return true;

		SMWParseData::stripMagicWords($text, $parser);

Once modified, SMW properties seem to work again and FCKEditor seems to operate as well.

This fix appears to work on mediawiki v1.15.1 with SMW v1.4.3 and FCKEditor v1.0.1 extensions installed. Used FCKEditor to save changes to pages with embedded SMW property declarations (ie. [[property::value]]) preserved.

comment:15 Changed 3 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy