Ticket #1100 (closed Bug: fixed)

Opened 7 years ago

Last modified 6 years ago

Indented number list adds </dd>

Reported by: nimdae Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Pending Cc:

Description

When creating a list, there are times I need an indention without the numbering, but numbering to continue. Here's some sample wiki code:

# Num listing one
## Nested num listing one
# Num listing two
#: Indention to num listing two
# Num Listing three

The #: line is not translated correctly. It will end up like this with FCKeditor in wikitext mode:

# Num listing one
## Nested num listing one
# Num listing two <dl><dd>Indention to num listing two</dd></dl>
# Num Listing three

Then for some reason, if I edit/preview again, it will screw up on the </dd> tag and we see this:

# Num listing one
## Nested num listing one
# Num listing two <dl><dd>Indention to num listing two&lt;/dd&gt;</dd></dl>
# Num Listing three

Every preview/update will re-render the </dd> incorrectly, which adds more </dd> tags to the displayed text.

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Pending added; mediawiki list removed

Hi! I was unable to reproduce your problem. Could please write what kind of browser are you using? My test results are different from yours. Your code:

# Num listing one
## Nested num listing one
# Num listing two
#: Indention to num listing two
# Num Listing three

is transformed to this code when switching between source view and wikitext:

# Num listing one 
## Nested num listing one
# Num listing two 
:Indention to num listing two

# Num Listing three

It is still a bug tough. Could you please check again and see if you have simillar results. Thanks

comment:2 Changed 6 years ago by wwalc

  • Status changed from new to closed
  • Resolution set to fixed

Fixed with [1860].

comment:3 Changed 6 years ago by wwalc

Plese post all problems with lists in ticket #1003.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy