Opened 3 years ago

Closed 3 years ago

#11823 closed Bug (fixed)

[IE8] TableResize throws error over scrollbar

Reported by: pjasiun Owned by: pjasiun
Priority: Normal Milestone: CKEditor 4.4.1
Component: General Version: 4.3.4
Keywords: Cc:

Description (last modified by pjasiun)

  1. Open table-resize sample.
  2. Add some empty lines so the scrollbar will show.
  3. Drag last pillar and move it so the mouse will be over the scrollbar.

Result: Error multiple times in the console:

Object doesn't support this property or method

First bad commit: git:4991411.

I wasn't able to reproduce it on IE9, IE11 and Chrome.

Change History (9)

comment:1 Changed 3 years ago by pjasiun

  • Description modified (diff)

comment:2 Changed 3 years ago by pjasiun

  • Milestone set to CKEditor 4.4.1

comment:3 Changed 3 years ago by m.lewandowski

  • Status changed from new to confirmed

comment:4 Changed 3 years ago by pjasiun

  • Owner set to pjasiun
  • Status changed from confirmed to assigned

comment:5 Changed 3 years ago by pjasiun

  • Status changed from assigned to review

It was possible to reproduce this bug also on FF.

The reason was missing events target document when the mouse was outside the editor. We could switch back to using editable instead of document (see first bad commit) but the we would lost benefits of using document (with document D&D works also below the body if body is small).

I decided to check if events target document exist instead and cancel the event if it's not.

Changes in t/11823.

comment:6 Changed 3 years ago by Reinmar

  • Status changed from review to review_failed

I force pushed rebased branch with additional commit simplifying and clarifying the target validation.

However, R- because tabletools tests fail.

Last edited 3 years ago by Reinmar (previous) (diff)

comment:7 Changed 3 years ago by pjasiun

  • Status changed from review_failed to review

I rebased branch, run tests and tabletools tests were green on IE8, FF and Chrome, but tableresize tests were red. If fixed those tests and pushed both branches.

comment:8 Changed 3 years ago by Reinmar

  • Status changed from review to review_passed

Ups, my fault - of course I meant tableresize tests.

comment:9 Changed 3 years ago by pjasiun

  • Resolution set to fixed
  • Status changed from review_passed to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy