Opened 3 years ago

Closed 3 years ago

#11880 closed Bug (fixed)

[IE8-9] Linked image2 has a too thick border

Reported by: Reinmar Owned by:
Priority: Normal Milestone: CKEditor 4.4.1
Component: General Version: 4.4.0
Keywords: Cc:

Description

It seems that adding border: none to a>img styles fixes this.

Change History (2)

comment:1 Changed 3 years ago by Reinmar

  • Status changed from new to confirmed
  • Summary changed from [IE] Linked image2 has a too thick border to [IE8-9] Linked image2 has a too thick border

comment:2 Changed 3 years ago by Reinmar

  • Resolution set to fixed
  • Status changed from confirmed to closed

Fixed on master with git:d8b7fc9. That was the default border which IEs were adding to linked images. It was not visible on other samples, because they contain styled image, and the style overwrites that default border.

So, since we apply outline to linked images, we have to reset that border. To be certain that we're not breaking something, I checked that the border set in image dialogs overrides the a>img style (what's obvious because image dialog uses inline styles) and as I mentioned earlier styles applied by styles combo has higher specificity too.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy