Opened 3 years ago

Closed 3 years ago

#11936 closed Bug (expired)

Text selection lost when using Browse Server in Link plugin

Reported by: OliUK Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.0
Keywords: Cc:

Description

In Firefox (Nightly, Aurora and 29), when selecting text in the editor and creating a hyperlink, when the Browse Server function is used, the text selection is lost and a new element is created rather than the text being turned into a link (see screenshot).

Steps to reproduce: (Using Firefox)

  1. Go to the demo at http://ckeditor.com/demo
  2. Select 'became the first to step' text (or any other text) in the textbox
  3. Click the link toolbar button
  4. Select Browse Server, then select any item
  5. The link will be appended as a new link with the link text, rather than making the selection a link

Other cases: In other browsers (such as Safari), the function works as intended

Choosing to upload a file rather than browsing the server results in the correct behaviour

If a link has already been created and is being edited, the link is successfully updated and behaves as normal

Attachments (1)

appendedlink.png (57.5 KB) - added by OliUK 3 years ago.
New link created rather than text updated with link

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by OliUK

New link created rather than text updated with link

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to pending

I have tried this on demo page and my local CKEditor 4.4 on Firefox 29.0.1 and all has worked as expected.

Could you recheck and let us know if you still get this problem?

Have you got any custom plugins installed on Firefox that might have some influence on this problem?

comment:2 Changed 3 years ago by Reinmar

I've checked it too and I also couldn't reproduce it.

comment:3 Changed 3 years ago by Reinmar

  • Resolution set to expired
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy