Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11942 closed Bug (fixed)

Enhanced Image dialog doesn't find it's caption on editing

Reported by: frietsch Owned by:
Priority: Normal Milestone:
Component: UI : Widgets Version: 4.4.0
Keywords: Cc:

Description

First seen locally, but easily reproducible on http://ckeditor.com/demo#widgets

If you already have an Enhanced Image widget incl. a caption in your page and you double-click to edit, the dialog has the caption checkbox *un*checked. Re-checking the checkbox creates a *second* nested caption.

Change History (3)

comment:1 Changed 3 years ago by frietsch

(I'm using Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 if that should be relevant)

comment:2 Changed 3 years ago by Reinmar

  • Keywords image2 caption removed
  • Resolution set to fixed
  • Status changed from new to closed

Thanks for notifying us. It was a bug in the sample, because the figure had caption class instead of image class.

You've seen this also locally, because prior to CKEditor 4.4 the caption class has been used so. In CKEditor 4.4 we decided that it was wrong and we had to change it. If you want to load your old content, please use the http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-image2_captionedClass option.

comment:3 Changed 3 years ago by frietsch

Actually, my problem was that I'm running a very restricted ACF that didn't allow any class on "figure". Took me a while to realize that, but now it works fine.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy