Ticket #1243 (closed Bug: fixed)

Opened 7 years ago

Last modified 20 months ago

Variable renaming doesn't work on specific case

Reported by: fredck Owned by:
Priority: Normal Milestone:
Component: Project : CKPackager Version:
Keywords: Cc:

Description

The following input:

function Test()
{
  for ( var idx = 0 ; idx < 10; idx++ )
  {
    if ( ( idx / 2 ) == x( idx / 2 ) )
       alert( idx ) ;
  }
}

Outputs like this:

function Test(){for (var A=0;A<10;A++){if ((A / 2 ) == x( idx / 2)) alert(A);}}

The "idx" variable is not always replaced by "A".

There are also some spaces that could be safely removed (near /), but this is another (minor) issue.

Change History

comment:1 Changed 7 years ago by w.olchawa

  • Keywords Confirmed added

comment:2 Changed 20 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

This issue expired since we use Google Closure Compiler.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy