Opened 2 years ago

Closed 9 months ago

Last modified 9 months ago

#12541 closed New Feature (fixed)

File upload plugin

Reported by: pjasiun Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.6.0
Component: General Version:
Keywords: Cc:

Description

When you drop a file upload starts and link to the file is created.

Change History (13)

comment:1 Changed 2 years ago by pjasiun

Plugin in t/12541. No tests yet.

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from new to confirmed

comment:3 Changed 2 years ago by Reinmar

  • Milestone CKEditor 4.5.0 deleted

A prototype of such plugin will be included in dev samples of #12541. But this plugin is out of 4.5's scope.

comment:4 Changed 2 years ago by pjasiun

Note: File name should be replaced with the name from the server after the upload, also spaces and in the file name should be encoded.

comment:5 Changed 20 months ago by pjasiun

  • Owner set to pjasiun
  • Status changed from confirmed to review

We decided to put this plugin to the separate repository, not into the CKEditor-dev, at least, for now. I rebased it on the newest major and fixed all issues. It also has a dev sample to check if everything works fine, but to make it works you need to have a CKFinder configured. The plugin has no tests and it will not have them at this form.

Changes in the ckeditor-plugin-uploadfile repository, t/12541 branch.

Last edited 20 months ago by pjasiun (previous) (diff)

comment:6 Changed 17 months ago by pjasiun

  • Milestone set to CKEditor 4.6.0

I moved the code to the ckeditor-dev repository. It is based on the major branch and target to the next major release (4.6.0) now. I also added test, both automated and manual.

Changes in t/12541.

comment:7 Changed 9 months ago by Tade0

  • Owner changed from pjasiun to Tade0
  • Status changed from review to assigned

The plugin, in general, works but I feel there's room for improvement. The first thing that comes to mind is the lack of integration with notifications.

Since @pjasiun is not doing CKE4 tickets anymore I'm taking over this ticket.

comment:8 Changed 9 months ago by Reinmar

What kind of integration do you mean?

comment:9 Changed 9 months ago by pjasiun

What is wrong with notifications there?

comment:10 Changed 9 months ago by Tade0

Turns out that nothing, and this was just a result of ticket:14375.

EDIT: Obviously I meant the ticket I changed to now. :D

Last edited 9 months ago by Tade0 (previous) (diff)

comment:11 Changed 9 months ago by Tade0

  • Resolution set to fixed
  • Status changed from assigned to closed

Corrected a few minor issues, apart from that, like was said before, the plugin works.

Added with git:99658068cb0137119c2e82d5539387291cc94505

Also, there's a PR in the docs repo concerning this ticket: https://github.com/ckeditor/ckeditor-docs/pull/67.

comment:12 Changed 9 months ago by Reinmar

Another thing to work on would be adding this plugin to one of the samples in the SDK.

comment:13 Changed 9 months ago by pjasiun

Resolution set to fixed

Yay! :D

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy