Ticket #1260 (closed Bug: worksforme)

Opened 7 years ago

Last modified 3 years ago

Inconsistent results when switching betwen Source view containing iFrame

Reported by: pjthiel Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version: FCKeditor 2.4
Keywords: Firefox Cc:

Description

I am having a problem when switching between source/render view in FCK when the source contains the following iframe code:

<iframe width="500" height="350" frameborder="0" scrolling="No" marginheight="0" marginwidth="0" src="http://maps.google.com/maps?f=q&amp;hl=en&amp;geocode=&amp;q=auburn+hills,+MI+48326&amp;ie=UTF8&amp;om=1&amp;s=AARTsJpdr6dyTOcbLJBOCfJjsMkq6xbZqA&amp;ll=42.720786,-83.229675&amp;spn=0.17656,0.343323&amp;z=11&amp;iwloc=addr&amp;output=embed"></iframe><br><small><a href="http://maps.google.com/maps?f=q&amp;hl=en&amp;geocode=&amp;q=auburn+hills,+MI+48326&amp;ie=UTF8&amp;om=1&amp;ll=42.720786,-83.229675&amp;spn=0.17656,0.343323&amp;z=11&amp;iwloc=addr&amp;source=embed" style="color:#0000FF;text-align:left">View Larger Map</a></small>

Steps to produce the problem:

  1. Load FCK editor
  1. Switch to source view
  1. Paste the above code
  1. Switch off source view

90+ times out of 100, the iFrame is not rendered and the source button becomes non-functional. However, I have been able to switch between source/render views with the above iframe before - and I can not discern what is wrong.

To further complicate matters, I can not reproduce this error on Firefox/Windows, nor IE7/windows ... the problem seems isolated to Firefox on my Mac! I can happily switch between source and non-source view, using the above iframe, on FF/IE on Windows.

I am running Firefox (Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6) on Intel Mac OS X 10.4.10

Any help would be much appreciated!

Change History

comment:1 Changed 7 years ago by alfonsoml

  • Keywords Confirmed Firefox added

Confirmed, with Firefox in Mac it fails.

I'm just guessing, but it looks to me like the script in the iframe is executed in Mac but not in PC, and that script messes up with the document in some way and then it can't be read (it clears the content of the parent iframe)

It should be tested with the firefox 3 alpha and then report it in bugzilla.mozilla.org if the content of the iframe inside a designMode document is executed.

comment:2 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy