Ticket #1279 (closed Bug: fixed)

Opened 7 years ago

Last modified 7 years ago

DOM range iterator incorrectly treats bookmark nodes as independent blocks

Reported by: martinkou Owned by: fredck
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: Core : Styles Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description

Reproduction procedure:

  1. Open sample01.html.
  2. Press Ctrl-A inside the editing area to select all.
  3. Press the Justify Center button, or the Indent button.
  4. An unneeded, empty paragraph is created before the selected block.

After some investigation, it was found that the empty paragraph was created because the DOM range iterator in classes/fckdomrangeiterator.js is treating the empty <span> node created by FCKDomRange.CreateBookmark() as an independent block. The bookmark node is only a temporary node not meant to be part of the document, and so it should be ignored by the FCK DOM range iterator.

Change History

comment:1 Changed 7 years ago by fredck

  • Status changed from new to closed
  • Resolution set to fixed

Fixed with [862] and [863].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy