Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1300 closed Task (fixed)

Enable Safari (WebKit) compatibility

Reported by: fredck Owned by: wwalc
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: Cc:

Description

Introducing the appropriate browser sniffing in the integration files to enable WebKit 522 (Safari 3) compatibility.

Generic rules for the user agent sniffing:

1# Check: Is Safari?

Check if " AppleWebKit/" is in UserAgent.

2# Check: Is compatible Safari version?

Get the number after " AppleWebKit/". It must be >= 522.

Change History (5)

comment:1 Changed 9 years ago by fredck

The JavaScript implementation has been introduced with [833].

comment:2 Changed 9 years ago by fredck

I mean... The JavaScript implementation has been introduced with [883], not [833].

comment:3 Changed 9 years ago by wwalc

  • Owner set to wwalc
  • Status changed from new to assigned

comment:4 Changed 9 years ago by wwalc

  • Resolution set to fixed
  • Status changed from assigned to closed

Done with [886],[887],[888],[889],[890],[891],[897].

AFP version has not been tested yet because I couldn't integrate AFP on my computer neither with Apache 2 nor IIS 5.0...

AFP and lasso versions don't use regular expressions to get AppleWebKit version, so we are safe until 1000 release.

comment:5 Changed 9 years ago by fredck

Sönke, our AFP maintainer, confirmed that the code is correct. He just pointed out that there could be issues with server configured to use commas for decimals separations. He proposed a solution... I've applied it with [907].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy