Ticket #1319 (closed Bug: fixed)

Opened 7 years ago

Last modified 7 years ago

fckw3crange.html : test_toString_W3C_1 fails

Reported by: hallvord@… Owned by: fredck
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description

Run automated tests from FCKEditor SVN.

Note error:

"trunk/_test/automated/tests/fckw3crange.html:test_toString_W3C_1 failed" Expected <his is some> (String) but was <his is some text.> (String)

Opera and Firefox both "fail" this test, it is probably broken.

Change History

comment:1 Changed 7 years ago by hallvord@…

  • Owner set to fredck

comment:2 Changed 7 years ago by martinkou

This is most likely caused by [806]. I changed the function to make it non-intrusive (i.e. not changing the document structure) when I thought I needed it in the indent commands. However, after writing the indent command logic, I figured out a way to do it without using FCKW3CRange.toString() or the related FCKDomRange.GetText().

So the new toString() code isn't needed by anything right now. Therefore, if the non-intrusiveness isn't considered important, this might be fixed by reverting to the code before [806].

comment:3 Changed 7 years ago by fredck

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to FCKeditor 2.5

I've dropped FCKDomRange.GetText and FCKW3CRange.toString with [978] as we are not using them at this moment.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy