Ticket #1340 (closed Bug: wontfix)

Opened 7 years ago

Last modified 7 years ago

Caret disappeares deleting a styled char

Reported by: pora Owned by:
Priority: Normal Milestone: FCKeditor 2.6.1
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Cc:

Description (last modified by fredck) (diff)

FCKeditor Nightly Built version:

  1. type some text
  2. use for it an inline style for example "Inline quotation"
  3. select a character inside the styled area
  4. use for it another inline style for example "Cited work"
  5. go one position left (or right)
  6. delete the character (with backspace or delete)
  7. caret disappeares (but pushing up or down comes at the first or at the last row)

Change History

comment:1 Changed 7 years ago by fredck

  • Version set to SVN
  • Description modified (diff)
  • Milestone set to FCKeditor 2.5

Reformatted the description for readability

comment:2 Changed 7 years ago by fredck

Actually it's much simple to replicate the problem. Just load the following code in the source:

<p>Some t<strong>e</strong>xt</p>

Back to WYSIWYG, place the caret before the bold "e". Hit Backspace to delete it.

The "e" will be correctly deleted, but the caret will disappear. Note that the Style combo is showing "Strong Emphasis", which means that the <strong></strong> element is still there, and the caret is inside of it (just type some text to check it). As the caret is inside and empty element, Firefox doesn't' show it (known FF issue).

In IE, we have the same behavior, but the caret doesn't disappear.

Strangely enough, for some elements it works well. Just replace <strong> with <b> or <i> and you will see that the entire element is removed, not only its contents, and the caret will not disappear.

comment:3 Changed 7 years ago by martinkou

#1428 marked a dup to this ticket.

comment:4 Changed 7 years ago by fredck

  • Milestone changed from FCKeditor 2.5 to FCKeditor 2.6

This is a browser bug. It is present in previous versions too. We'll not be blocking the 2.5 for it right now. Let's postpone it.

comment:5 Changed 7 years ago by w.olchawa

  • Keywords Confirmed added

comment:6 Changed 7 years ago by fredck

  • Milestone changed from FCKeditor 2.6 to FCKeditor 2.6.1

comment:7 Changed 7 years ago by martinkou

  • Status changed from new to closed
  • Resolution set to wontfix

This is a Gecko browser bug, and from the tests I did today... It seems to be fixed in Firefox 3 already.

The behavior in IE is ok. Actually I think it's what most users expect.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy