Opened 21 months ago

Closed 2 months ago

#13793 closed Task (fixed)

Embed plugin: use empty embed_provider by default

Reported by: wwalc Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.7.0
Component: General Version: 4.5.0
Keywords: Cc:

Description

The embed plugin has now //ckeditor.iframe.ly/api/oembed?url={url}&callback={callback} URL set by default as providerUrl.

As the default anonymized API end point has certain restrictions on its usage, it's better to make sure that each user using this plugin is aware of limitations (otherwise there is a risk that suddenly on a production website this service will stop working_. This effect can be only reached by removing the predefined end point n the plugin configuration and having users reading the documentation in order to specify it manually.

The documentation should list //ckeditor.iframe.ly/api/oembed?url={url}&callback={callback} as a "ready to use" option, but it should also recommend setting up an account on Iframely to better track the API usage (even in the free "Developer" tier plan).

Change History (12)

comment:1 Changed 21 months ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 11 months ago by Tade0

  • Owner set to Tade0
  • Status changed from confirmed to assigned

comment:3 Changed 8 months ago by Tade0

  • Status changed from assigned to review

Updated the default and the docs accordingly, changes pushed to branch:t/13793.

Relevant pull request in the docs repo: https://github.com/ckeditor/ckeditor-docs/pull/71

comment:4 Changed 8 months ago by m.lewandowski

  • Milestone changed from CKEditor 4.6.0 to CKEditor 4.6.1

comment:5 Changed 7 months ago by m.lewandowski

  • Milestone changed from CKEditor 4.6.1 to CKEditor 4.6.2
  • Status changed from review to review_failed

Editor should report an error explaining the reason of the problem in case of missing embed_provider. Use `error` method for this purpose.

Last edited 7 months ago by m.lewandowski (previous) (diff)

comment:6 Changed 7 months ago by Tade0

  • Status changed from review_failed to review

Added this. Error explained in the associated docs pull request.

comment:7 Changed 6 months ago by m.lewandowski

Pushed a couple of changes to t/13793 branch, now it looks pretty much fine, but the related docs pull request needs to be adjusted.

comment:8 Changed 6 months ago by m.lewandowski

  • Status changed from review to review_failed

comment:9 Changed 6 months ago by m.lewandowski

  • Milestone changed from CKEditor 4.6.2 to CKEditor 4.7.0

Moved to major milestone, as we don't want to make such a breaking change in a minor release.

comment:10 Changed 4 months ago by Tade0

  • Status changed from review_failed to review

Updated the docs as requested.

comment:11 Changed 2 months ago by k.krzton

Rebased on current major, corrected docs typo and added unit tests. Created PR https://github.com/ckeditor/ckeditor-dev/pull/342.

comment:12 Changed 2 months ago by m.lewandowski

  • Resolution set to fixed
  • Status changed from review to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy